need help in andriod eclair build

  • Replies:0
  • OpenNot stickiedUnanswered

Apr 15, 2011 5:37:17 AM via Website

i am trying to build android eclair version and i am getting some build error
/********************** log file *******************************/
Build android for smdk6410

[[[[[[[ Build android platform ]]]]]]]

make -j1 PRODUCT-sec_smdk6410-eng

============================================
PLATFORM_VERSION_CODENAME=REL
PLATFORM_VERSION=2.1
TARGET_PRODUCT=sec_smdk6410
TARGET_BUILD_VARIANT=eng
TARGET_SIMULATOR=
TARGET_BUILD_TYPE=release
TARGET_ARCH=arm
HOST_ARCH=x86
HOST_OS=linux
HOST_BUILD_TYPE=release
BUILD_ID=ERD79
============================================
build/core/copy_headers.mk:15: warning: overriding commands for target `out/target/product/smdk6410/obj/include/libpv/getactualaacconfig.h'
build/core/copy_headers.mk:15: warning: ignoring old commands for target `out/target/product/smdk6410/obj/include/libpv/getactualaacconfig.h'
/bin/bash: line 0: cd: sdk/layoutopt/app/src/resources: No such file or directory
build/core/Makefile:17: warning: overriding commands for target `out/target/product/smdk6410/root/init.rc'
system/core/rootdir/Android.mk:38: warning: ignoring old commands for target `out/target/product/smdk6410/root/init.rc'
host C: acp <= build/tools/acp/acp.c
cc: No such file or directory
make: *** [out/host/linux-x86/obj/EXECUTABLES/acp_intermediates/acp.o] Error 1
Total compile time is 52 seconds


[[[[[[[ Make ramdisk image for u-boot ]]]]]]]

./build_android.sh: line 45: mkimage: command not found
/*****************************************************************************/

can anyone pls help me what is causing that and how can i resolve it

cross compiler : - cross-3.3.2
toolchain:- 4.3.1-eabi-armv6-20080707
host pc:- ubuntu 10.04 ---- (kernel---2.6.32-24-generic)

before running the ./build_android.sh i ran these commands also

sudo apt-get install vim
sudo apt-get install gcc build-essential fortran77-compiler make
sudo apt-get install gawk
sudo apt-get install automake autoconf
sudo apt-get install minicom lrzsz
sudo apt-get install linux-headers-$(uname -r)
sudo apt-get install ncurses-dev libncursesw5-dev libncurses5-dev
sudo apt-get install netpbm libnetpbm10 libnetpbm10-dev
sudo apt-get install libtool bison flex texinfo \binutils-dev libc6-dev linux-libc-dev
sudo apt-get install manpages manpages-dev \manpages-posix manpages-posix-dev

and i tried on java version :-
java-1.5.0-sun 53 /usr/lib/jvm/java-1.5.0-sun
java-6-sun 63 /usr/lib/jvm/java-6-sun

i got same error both times

thanks friends
manoj kumar