Samsung Galaxy S2 — Problems with enabling HSDPA mode.

  • Replies:1
  • OpenNot stickiedUnanswered

Jul 11, 2011 11:25:38 AM

Hi,
I am trying to enable 3G on my phone, it gives 3 options for network mode as GSM/WCDMA (Auto mode), GSM only and WCDMA only. There is no option for HSDPA. I have checked in phone spesification that it has got HSDPA. Could you please clear my doubts why HSDPA has not been listed in network mode for my phone? or It is by default there for galaxy s2.

Thanks in advance...