Samsung Galaxy S2 — help please

  • Replies:6
  • OpenNot stickiedUnanswered

Apr 3, 2012 8:36:42 AM

It seems that you have done an update via Kies - official update- and have forgotten a very important step-------- Full wipe.


This is a typical symptom of an update where the full wipe option was not done afterwards.

I recommend boot to dev mode turn on device holding middle button and volume rocker up- then do full wipe and factory reset. Presto - lag is gone and your new version is fresh and fast.

Question: whay are you not using ICS version 4.0.3--- 2.3.5 is old news. Also 2.3.6 has been out for quite some time.

Look in the Galaxy S2 thread and you will see my link and instructions to go to ICS

Enjoy and good luck

Apr 3, 2012 6:06:18 PM

Christopher Silva
It seems that you have done an update via Kies - official update- and have forgotten a very important step-------- Full wipe.


This is a typical symptom of an update where the full wipe option was not done afterwards.

I recommend boot to dev mode turn on device holding middle button and volume rocker up- then do full wipe and factory reset. Presto - lag is gone and your new version is fresh and fast.

Question: whay are you not using ICS version 4.0.3--- 2.3.5 is old news. Also 2.3.6 has been out for quite some time.

Look in the Galaxy S2 thread and you will see my link and instructions to go to ICS

Enjoy and good luck

Agreed. Doing an update without a full wipe will lead to nothing but lag and bugs. Very important step.