HTC Sensation XE — Wrong Time Zone GMT

  • Replies:7
  • OpenNot stickiedUnanswered

Apr 23, 2012 2:02:48 PM via Website

Recently I found out that receive's time of every messages I got from friends is one hour ahead of actual time.
this take me several days to figure out what causing it , and this is my conclusion :
I live in Tehran which time zone is +3:30 GMT without DST (Daylight Saving) , there is no option in my phone to disable DST, and android automatically add one hour to it and make it +4:30 GMT when it is summer times, so when I receive a message from a friend who's time zone is +3:30 my phone will automatically adding an hour to the sending time to match it with my phone's time zone.

I searched a lot and didn't find a way to prevent the phone from doing this, how can I disable DST ? or other way to prevent the phone from considering DST for my time zone ?

Apr 25, 2012 4:35:08 PM via Website

Cant you just go into settings - date and time - and disable the top 2 options (automatic date and time and automatic time zone) and then set the time and date manually?

Apr 29, 2012 5:14:42 AM via Website

I did that but it didn't solve the problem and whenever I receive a message from a friend who doesn't have android phone the send time is 1 hour ahead of actual time. !

Jun 3, 2012 7:36:09 AM via Website

I have the same issue now. I didn't have this problem until i just updated my software to the new HTC sense 3.6 version and now my time keeps changing automatically.

Jun 5, 2012 4:39:08 PM via Website

CRAP. Have you guys checked the release notes for the 3.6 Sense update to see if this is a known issue? I havent heard of it happening before now.

Nov 10, 2012 12:00:12 PM via Website

Hi, This happened to me as well, when my country switched to winter time few weeks ago. Since then, all my emails and text messages are one hour behind. It seems that Network provides phone with wrong timezone information (or not disabling DST as it should). So I had to use manual time, which causes one hour delay problem. I contacted my phone company, they were not aware of such issue, so it seems it is quite rare, but still exists..

Jan 6, 2013 9:38:33 PM via Website

Hi Andis. At seems that we have the same problem - because of Daylight Saving Time change in our country Latvia.

Also, my problem a different from yours - i receive messages with the correct time, while the TIME shown on startup desk with the weather spoiler is wrong. It shows 1 HOUR further.

I tried changing the setting manually - the problem still occurs. I disabled the "automatically" settings, because it sets my time +1gms, and while phone time shown correctly time on the header (phone icons place, time is shown on the right top corner), the time on weather widget is 1hour more for example time is 22:37 and the weather widget shows 23:37.

Question: How do i fix it, or how to reset this DST settings. My older phone LG secret 750 had this setting.