Connects to Router but No Internet

  • Replies:4
  • OpenNot stickiedUnanswered

Aug 11, 2012 1:56:40 PM via Website

After searching not just this forum but google as a whole, I am completely stuck!

We own several different HTC and Samsung "smartphones", Laptops and more that all use our Home WIFI network.

Until two days ago all connected to the router and then on to the wide world beyond without a single issue, but now the phones connect to the router as usual but don't see anything beyond the local network.

The laptops work fine still. The phones will use the WIFI network and happily sync and communicate with the laptops no problem, but refuse to see the internet. Therefore no email, no market updates, no anything.

If you use the in-built browser and simply head to google, it times out saying page not available.

What's changed on the network...just one key thing.

I have just installed some CCTV with a DVR that allows remote viewing. To make this work I had to change one setting on my router.

Since I don't have and can't get a static IP address I needed a Dynamic DNS service. Easy. For that to work though I had to change my router settings from "Get DNS Address Automatically From ISP" to fixing the Primary & Secondary DNS servers. I used 64.24.218.220 and 64.24.218.221 respectively (still my ISP servers, although I know I can use any DNS servers).

The DVR works great and my camera's can be seen via my dnsdomain by friends and family anywhere in the world (great for when we go away etc).

The laptops, as I say, work fine.

All our Android "smartphones" stopped working at once.

Obviously, I can get them working by setting my router back, but then the remote viewing on the DVR/CCTV won't work, which I need.

Has anyone had similar issues/configuration that they managed to overcome and help an enthusiastic technology newbie with please?

Aug 11, 2012 8:04:03 PM via Website

Think I solved this...mostly anyway...



I simply changed my DNS Servers (gateways Primary/Secondary) to Googles instead of my ISP



Didn't change anything else, just rebooted the lot and it works



Email & internet fine, but the Play Store still doesn't work

Aug 11, 2012 9:19:56 PM via Website

Many Routers have the ability to add a "DHCP Reservation" per device.
Kind of a "SUDO" static IP setting for that device, meaning your can leave Dynamic DNS service running for all other devices.

View this d-link emulator below for an example:

http://support.dlink.com/emulators/wbr2310/lan.htm

Jan 7, 2013 9:51:09 AM via App

sorry I can't help. just want to add my voice. I've been feeling like my situation is unique. hallelujah! now I know it's not. four days ago my phone lost the ability to search the web via my WiFi network. 'til then, no issues. since then, I can still connect to my LAN but the phone doesn't seem to recognise anything beyond that. "page unavailable". "could not load page". is about all I've seen on my phone while connected to WiFi in the last four days. pc works fine. no dramas there. internet service provider blames phone manufacturer. phone manufacturer don't seem to want to talk to me. phone service provider aren't interested in internet issues. feel like I've been running around in circles for four days on this! I feel for you. hope your issue can be sorted soon. if I can sort mine, I'll let you know what happens!

Jun 10, 2014 5:20:36 AM via Website

Has anyone found a resolution for this.... my HTC phone just did the same thing. Everything was working fine... then I could connect to my Linksys router but no internet traffic. This has now also affected our Samsung tablet. All other Samsung, Apple and Blackberry phones in the house work fine on Wi Fi. So do all our computers which all connect wireless. Is this a problem with the router or the devices? Does anyone have a fix?

FYI, I have 'factory reset' both the phone and the tablet trying to resolve the issue with no luck. If I take the phone or tablet to a Starbucks... they connect and work fine... just extremely inconvenient doing that everyday...!!

Any help would be greatly appreciated.