Wifi problem - 'On' but no wifi icon and not working

  • Replies:1
  • OpenNot stickiedUnanswered

Jan 11, 2013 12:02:25 PM

Hello all,

I have a Philips W626 (an unusual brand/model I know) and have recently got a problem with the wifi on this phone. It was working fine before.

The phone is rooted.

The wifi is on according to the phone, it displays available connections but won't connect. The wifi status remains on 'scanning' even though there are lots of connections available (which I've conncted to previously) and then 'disconnected'. When I try and connect, it just says, 'connecting...authenticating...disconnected'. One connection says 'Disabled' but I can connect to it on my laptop just fine.

Even though when I go into settings it says wifi is enabled, no 'wifi icon' appears in the status bar.

Tethering doesn't seem to give me internet access either.

I'd really appreciate your help.

Jul 14, 2013 12:13:44 AM

This is what i did and it worked for me:

GO to your android phone wifi settings..turn on the wifi...make sure u entered the pin and it is authenticated and saved...wifi icon not appearing in top status bar at this time
so once u go to andrid settings..click on the options/menu let touch screen button on my phone and then it will give u an option to add WPS PIN

click on it and it will generate a PIn and ask u to enter it in the router

i have a netgear router so i opened my laptop internet explrer..entered netgear URL 192.168.1.1/start.htm and on left menu i cicked on "Add WPS Client" and entered the PIN generated on android phone by selecting that option.. once u enter the pin..look at ur phone and it will refresh and the wifi icon will appear