Google Nexus Tablet — Installing books on Nexus

  • Replies:4
  • OpenNot stickiedAnswered

Jan 1, 2014 10:49:02 PM

Hi, I have registered with the forum as i have been given a Nexus 7 Tablet for Christmas. I have Installed Apps, Music and Films ok but i cannot install books. I imagine that they are Drm protected. I have installed Adobe Digital rights on my PC and can read the book on the PC but not on the tablet I have installed Adiko reader on the Tablet. I put the book Epub APK file in the folder named Ebooks and when i open Adiko the books dont show. My Brother has a Nexus 10 and he said he couldn't put books on that either. The books are downloaded from sites not Google playstore or Amazon. If anyone can run through what i need to do i would be most grateful. Thanks

— modified on Jan 2, 2014 1:19:43 AM

Jan 1, 2014 11:10:16 PM

Hi Terry, welcome to the forum and a happy new year. Here's a couple of possible resolutions ;)

Check that the ebooks are in correct ePub format (i.e. they don't have any extra file extensions, some downloaders/torrents do that) and that they're put in the folder 'eBooks/import'. Also check that the folder doesn't contain a file called .nomedia .

When you press 'import' in the Aldiko app does it look like anything is happening? It can take a while for the books to move from the sd to the internal memory(depending what version of aldiko you have)

Have you tried any other reader apps such as kindle, moon reader etc?

Sinkster

Jan 1, 2014 11:21:43 PM

Thanks Sinkster for the quick reply. And a Happy New Year to you. The book i'm trying to put on downloaded in 3 files. Mobi, Epub and Pdf. I cant see any extensions. When i put the file in before i installed Adobe Digital Editions. I could read the book on the tablet but it kept freezing when i turned the pages. Now i have installed Adobe it doesn't show at all. I didn't know about Kindle or Moonreader. Ill try them and let you know. Thanks again

Jan 2, 2014 10:27:08 AM

Thank you for the help. I dont know what i was doing wrong but after trying again it now works fine. I have sent an Email to my Brother how to do it, so theres two happy Bunnys Thanks again.