How to install Google Play Store (if it is not pre-installed)

  • Replies:6
  • OpenNot stickiedUnanswered

Feb 6, 2014 6:44:12 PM via Website

You might pick up a tablet in China or another device around the traps that doesn't have the Google Play Store pre-installed. Getting it on there is actually pretty simple. This method requires root access.

Download a couple of APKs, you can usually find the newest bundle in a zip package on XDA Developers:

  • Google Play Store (the newest version you can find)
  • Google Services Framework
  • Google Login Service/Account Manager
If you are rooted you can copy them to your root directory to System/App using a root manager like ES File Explorer. Then just restart your device.

If this doesn't work first time you might need to change the permissions on the new APKs to match the rest on your device. Use a file explorer like ES for this. Apparently if you're not rooted you can simply install each APK then reboot and it works for some devices. This sounds a little fishy to me but you never know.

Reboot and add your Google account in Settings > Accounts > Add account.

Look for the Play Store in your app drawer and hey presto!

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

Feb 10, 2014 4:53:07 PM via App

actually it is possible without root too, just to install the google play service apk, after that i think that running it and login in should just downloading it itself, i know it worked without root

Feb 10, 2014 5:57:07 PM via Website

Ah cool, @ Apolzan, so you did the non-rooted APK install version and it worked fine? Good to have confirmation. Just for our readers, all you did was install the Play Store APK and the rest sorted itself out?

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

Feb 12, 2014 2:26:15 AM via Website

yes,but i installed the google play service apk,not the store apk and it worked out like a charm without root,i think that installing the service,that has an option of installing the store too,i don't remember well,but that device i still have it and it's still unrooted,anyway it's no big deal to install the store after the service if it won't install by itself,thing is that it will ask to accept the google agreements of the true android device blah blah i think hahaha,like that is gonna stop any of us to use the google onour android devices :P

May 24, 2014 2:35:04 AM via Website

I try to install Google play service without rooting. After I installed Google service APK and open it, I got a message that "Google Services stopped unexpectedly, try again". Did anybody encounter this situation?

May 31, 2014 8:15:36 PM via Website

Try going into your settings and into apps, then scroll to the Running tab, and clear the cache and data from Google Play Services and then try again. You an also try removing your Google account and then re-adding it.

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting