Question about touch problem

  • Replies:5
  • OpenNot stickiedUnanswered

Feb 15, 2014 4:07:15 PM

I have had my phone for a few months and when I got it it worked fine.
One day I noticed that the screen was unresponsive but only at the bottom (see red rectangle in image) - I rebooted and it was fine again.

last week I noticed it was unresponsive at the bottom of the screen again, as well as the back and menu buttons stopped responding.
A reboot got the back/menu buttons going again - but not the bottom of the screen.

Today I find the back/menu buttons not longer respond again and rebooting does not restore the functionality.

My question is - is this likely to be a screen problem or is it possibly a software issue?

Any comments would be appreciated.

Feb 17, 2014 11:09:13 AM

Mary Mod
Hi Pewe, please let us know what phone this is. thanks :grin:

Sorry, its a Feiteng N9300 running Android 4.1.1 (an S3 clone I believe).

Feb 17, 2014 11:27:45 AM

There are a few things that can cause this kind of fault. Have you changed anything on the phone like screen resolution, or installed a new keyboard/input app? Plus, is it completely stock or is it rooted? Or have you had any updates recently? It might be hardware related as there are a few reports of this issue on some forums.

Sinkster

Feb 17, 2014 1:36:35 PM

sinkster
There are a few things that can cause this kind of fault. Have you changed anything on the phone like screen resolution, or installed a new keyboard/input app? Plus, is it completely stock or is it rooted? Or have you had any updates recently? It might be hardware related as there are a few reports of this issue on some forums.

I had various apps installed on the device which is stock and not rooted.

When the problem first appeared a month or so ago I did a factory reset which cured the menu/back button but not the bottom of the display. But the menu/back button problem came back the other day.

Since my OP I have again done a factory reset and this has once again cured the menu/back button but not the display (the red rectangle area).

I have not managed to find any info on the problem anywhere else so far hence posting here.

If this is a hardware fault, is it likely to be the digitizer or the lcd that is at fault?? Any ideas?/

Feb 17, 2014 2:31:14 PM

Ok, did a little research and it seems that there's a black version and a white version, but they have different firmwares :blink:. If you flash the wrong one then apparently the touchscreen stops working, I can't say if this is your issue but it possibly could be. This link is for the black version, if that's what you have then read the thread(s). If not I'll try and find something for the white one. lol just noticed your picture of the phone. It's black...

— modified on Feb 17, 2014 3:16:44 PM

Sinkster