Browsers don't connect to local IPs or hostnames

  • Replies:3
  • OpenNot stickiedAnswered
Deactivated Account
  • Forum posts: 21

Dec 25, 2010 1:36:10 PM via Website


admittedly I'm really new here in the Android scene (got my phone two days ago :grin:) but I'm really not wet behind the ears any more and so i ran into this annoying problem:

The browsers on the phone (Opera Mini as well as the default one) can't connect to my local webserver. All other PCs here in my LAN can reach the webserver via IP or hostname (the latter is possible cause i run a DNS on it too). But both approaches don't work for the browsers on the phone. A connection via SSH using ConnectBot works just fine.

What's the problem here and how can I fix/work around it?

Thanks in advance!
Deactivated Account
  • Forum posts: 21

Dec 25, 2010 2:42:11 PM via Website

Problem "solved".

I forgot to test the default browser using the IP. That works. But for using the hostname i had to prepend "http://". Otherwise it googles the hostname (... what a stupid behaviour not to ask the DNS first).

And Opera Mini sends all request to a proxy first (... even more stupid than the default browser).
Deactivated Account
  • Forum posts: 21

Dec 27, 2010 5:35:47 PM via Website

Douglas Carter
Good to see you got your problem solved so quickly.
Yeah, I got some help in another forum.
How do you like the Android OS and your phone itself?
Android is way friendlier when developing or deploying software than iOS. That's why i chose it. I can say, that I developed kind of seriously on Android, but that was before the 2.x versions. Maybe, you know Hoccer. Part of my internship i worked at the company in the group, that developed it. I learned a bit about the Android internals and have to say: although it's very open, it's still a little bit too restrictive for me. But i like the idea though :)
The phone itself is really nice, especially the hardware keyboard feels pretty good. I got it for 250€ (which is about 330$) and I'm very happy with it, although the screen resolution is very low, but .. you know .. I don't want to do photo editing on it :D
It definitely sounds like you are an experienced tech user.
Maybe more experienced than others due to the fact that I'm a Linux fanboy :P