e belkin tablet android 4.0

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Mar 14, 2012 1:37:03 PM via App

hi I have the above tablet and several apps are saying not compatible with this device wat is the problom
  • Forum posts: 742

Mar 14, 2012 5:15:08 PM via Website

Certain apps are not compatible with ICS yet, like cut the rope etc. You'll have to wait on the developers.