ICOO tablet wont boot up

  • Replies:23
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jan 14, 2013 12:33:21 AM via Website

I have an ICOO D70 Pro ll tablet that wont boot up, when I turn it on the ICOO boot up screen comes on for a few seconds then goes off. A screen with a battery with a gold triangle then comes on a few secs. then off. Can anybody help?
  • Forum posts: 1

Jan 20, 2013 5:01:10 AM via Website

I had the exact same problem, they wanted me to send it back but that would have been the same price I paid just to ship it. And problems started on the first day i received it.

Anyways, here is how I got it to work... icoo d70 PROII

I stuck a pin in the reset button at the top, between headphone and sdcard slot, and held for as long as I could, a couple minutes at least, that seemed to get it to boot up. The battert is still absolute garbage, highest I have gotten it to charge to was 99% but seems to just sit around 77% while plugged in, if I unplug it it will drop fast and takes days to get back to 77%.

Hope that helps.
  • Forum posts: 1

Jan 27, 2013 6:49:27 PM via Website

Hi Firstly great help for me with the same prob as you thanks. I have had other problems with this tablet that you may also experience : The tablet can sometimes get stuck in a boot loop ie it just keeps on trying to boot up and fails and then repeats the process again and again .The solution which I found online is to hold both the power on button and the volume up button in for at least 5 seconds and this should solve issue.Any way Thank you and I hope I have helped others out there Cheers
  • Forum posts: 5

Mar 24, 2013 10:55:02 PM via Website

Hi, I'm facing the same trouble... power up, battery with red triangule and shutdown... I'm afraid I don´t understand if you can solve the trouble with the "reset button", I've tried it whitout result, I was take out the white plastic cover and with a multimeter check the voltge of the battery, (3,50 v) battery label said 3,7 3000mah.

The following steps was follewed unsucessfully:

1_ REfalshing last firmware from the icoo site (sequence, power + volume+ holding), installing drivers, and reflash procedure with Rockchip Batch Tool v1.5.3.0.
2_ (sequence, power + volume- holding) shows same battery with red triangule and shutdown.

any ideas ? something that I missed up?

a picture of uncover tablet and error screen

  • Forum posts: 1

Apr 3, 2013 6:06:31 PM via Website

I bought one of these, because someone recommended it in another forum I belong to. Basically, this is a useless piece of garbage. Mine will not reset. I've tried the power button/up volume... I've tried the reset hole... I've tried anything I could think of. The only different thing I can report is... if I try the reset with the power button and up volume... after the initial ICOO white screen, I get a black screen with the Android robot laying on his back with his front panel open and a red triangle with an exclamation point.

What to do next... other than throw this in the trash can? :mad:
  • Forum posts: 5

Apr 4, 2013 2:32:07 AM via Website

I'm sorry to listen that, I've already known seven tablets that are working ok,,(can be rooted and swapping internal memory with external card and having 32gb of storage.)
in only one case the trouble was solve doing a reflashing as I've explained before.
In my case, the tablet finally get working, but the trouble was the micro usb-port charging conector, it is having a bad electric contact so it is not charging well...taht was the reason of the lying battery icon.
In your case of android lying down... there must be a secuence to go into recovery system console, I've get this secuence only one time.. pressing several time volume up/-, I should recommend to do a reflashing after throwing away.
good luke
  • Forum posts: 3

Jun 21, 2013 8:23:30 PM via Website

My android tablet Icood70proII is stuck on the screen with linux penguins , everytime i turn it on the penguins dissapear after a couple of seconds , i tried reseting it using the pin/needle and i tried using volume + and power but it still doesnt work .
Please help me!!!
  • Forum posts: 5

Jun 21, 2013 9:29:20 PM via Website

Hi Adrian,

I've handle at least three Tablet with this behavior, What I did in every case was to "flash" whit the latest bios. It is a simple procedure. you can contact me by message with and email for more details (I'm a native Spanish speaking form Argentine), but essentially you should:

Download Rockchips RK Batch Tool v.1.5 (at least I've used it)
Get and image from icoosoft in h t t p : / / soft.aoicoo.com/soft/UploadFile/xtgj/D70PRO-2%E5%8D%87%E7%BA%A7%E5%9B%BA%E4%BB%B61101.rar
or check for a newest version in h t t p : / / soft.aoicoo.com/soft/show.asp?id=285, (and Yes unfortunately it is in Chinese, it is understandable using google translator).
There are several guide on internet about how to use RK Batch Tool, but keep in mind change the .INI file to get info in English (option2, for default is in... Chinese!!).
Do you for sure should have to install special usb drivers for flashing (all are in the RK Batch Tool downloads).
After flashing don´t worry, because the default language of the tablet is... Chinese... but you can use the menus, for accessing the config section, language and change to desirable language.
  • Forum posts: 3

Jun 22, 2013 10:51:20 AM via Website

Hey leo , Do i just need to plug the tablet INTO my computer using the usb cable?
Also will I lose everything after I flash it?
  • Forum posts: 4

Jun 22, 2013 12:55:35 PM via Website

I did it and it actually worked for me. Thanks.
  • Forum posts: 5

Jun 22, 2013 3:27:04 PM via Website

Yes plug into the computer, install drivers from rktool, and follow the procedure, and YES all data will be erased.,
Normal (or at least after flashing) NOT showing penguins.
I hope you can solve it
  • Forum posts: 5

Jun 22, 2013 3:28:41 PM via Website

Great !!, I'm really dont know why are selling the tablet with an old flash.. I've seen several bougth them in the same weeks and two of them came with this old flash..
I'd like to listen that you sole the problem
  • Forum posts: 3

Jun 23, 2013 5:12:19 PM via Website

I'm not able to turn into the volume + and power state because it just goes into the penguins and then it turns off.
  • Forum posts: 1

Jun 23, 2013 9:13:55 PM via Website

don't bother reflashing the thing. The issue with this is that the lazy chinese who made it saved on solder when they soldered the micro usb connector. So, instead of soldering the 4 pins of the ground in the aforementioned connector, they only did two. As a result, when you accidentally tilted the tablet while USB was connected you tore off some of the pins from the main board. So go get yourself some very thin-headed soldering iron or go to a phone repair shop, they'll fix it. Just don't push it anymore, it'll break for good and will take the ultra-thin copper connection from the board with it.
  • Forum posts: 1

Jul 10, 2013 3:59:14 PM via Website

I Have a ICOO D70 pro II and when I turn it on, the two linux penguins appear and stay. It doesn't move further than that. I have clicked the on and off and reset button various times and hasn't caused any effect.

Can anyone help me fix it ?
  • Forum posts: 1

Jul 18, 2013 3:11:11 AM via Website

Hi i have ICOO D70PRO 2, it is causing a problem.. it's do on but it stuck at Android screen..i have no battery Issue..how i can flash my Tablet.

— modified on Jul 18, 2013 3:11:53 AM

  • Forum posts: 2

Dec 11, 2013 7:57:12 PM via Website

Hey......MAY have found a solution to a few issues I read on forum....I as well had the same problem, and I DO also being a person who used to work on circuit boards ect (made Ram)in the past and also corrected mistakes and solved issues with cracked boards, cracked solder ect.....I was having the same issue as a few others.....IF "ICOO D70PRO 2" came CLOSE to even booting up....would should the 2 icons, the triangle, AND EVEN at times a QUICK glimpse of the batter(sometimes with Triangle as well ..(as in about to charge OR 'Battery LOW'.?).

Well I DID open a few times carefully, and LOW and BEHOLD this time the MICRO USB (this is after already ordering a NEW tablet, different BRAND!)(yeah heard same thing, BUT why pay for shipping on something that costs only about a little more than 2x the shipping cost?...not realistic)....The USB just HAPPENED to come off the board, I noticed NO solder if there was it was SO little it stayed on the shiney metal area and was hanging on to that ALMOST 100, the connector to the board looked untouched by any solder ect.

Also Notice the batter myself, yes I think POOR too, came FULLY charged when send and WAS impressed, with both the fact that it had stayeeed charged all that time(in box and during shipping, but noticed seeing watching video (whicch is actually good through the HDMI mini on the tablet!....loss of battery, TOO quick to watch movies longer than 1.5 hours UNPLUGGED.....so was keeping plugged in...thought it was out home power, NO, the charger internal doesn't KNOW when to stop charging the battery, and/or IF doesn't recognize when Plugged in and eventually shuts down......had no problems with this and browsing....if solved will post, because looks like a simple solder fix, if so, a handy friend if can't do yourself....maybe ask....just be careful....just UN REAL how detached and lack of solder was on the board(connector for speaker/mic area as well.....Poorly made....again hense why so CHEAP(to buy), even though the Quality I WAS impressed with initially......WAS.

  • Forum posts: 2

Dec 11, 2013 9:32:49 PM via Website

Ok, under CLOSE observation, THIS is one of THE POOREST USB POWER-UP/connectors I have ever seen....I got all my gear together....and after final inspection, it simply comes to THIS folks.....and glad for myself too!...(the new tablet I ordered, DOES have a Micro UBS connector for connection to USB, but the POWER switch is a regular, circular, + & - that goes to an adapter, will take too long to take pics, but STILL may just to give a HINT and likely post on YouTube as well, reason:MOST w/o a problem will think 'Oh, USB, can charge with adapter & or PC ect"......NO, the pins ARE HORRIBLE, the fitting to the board PATHETIC(I WOULD advise that IF wanting to connect to PC/Mac/charger....OFTEN, either before or AFTER fixing....keep a micro-'USB' intact.....and that way you can add an adapter to the size....because what I'm about to do is 'bridge' all connections from what was left of the pathetic pins, to the circuit board....with some VERY VERY tiny wires....not the the beginner folks, you'll ruin the board....been na few years for me, but i did work with a chip we used to call 'fine pitch'..and will require some 'flux' as well......or it will be just a BIG mound of solid lead paste 'GUNK'!......maybe if able and when done, I'll post so people can see how (if able to make this work), and if can't do, a friend to how-to doing this....glad I paid so little for this....as I found the 'rock-chip' FAST, SMOOTH, and the picture and touch screen on this model a STEAL for the price......too bad this had to ruin it, likely that and a battery, with WILL be (size able) MUCH, MUCH easier to fix, being its only the 2 regular wires. Hate to say this but if something I had worked on with the company I used to work for....and other smaller details(but didn't effect LARGE issues like this!)....4 Shame!
  • Forum posts: 1

Jan 11, 2014 1:15:52 PM via Website

So, did you actually do this repair? I have a tablet where the USB socket is completely gone and I need to get a new part to solder in place.
Anyone know the details of a suitable socket for the Icoo D70G1?
  • Forum posts: 11

Aug 13, 2014 11:31:45 AM via Website

I'm sorry to hear that. I had an ICOO D70M tablet PC not long ago. It works smoothly right now and I wish it can last as long as possible. The answers to your post are informative.