How to Hard Reset your Google Nexus 7 (2013)

  • Replies:39
  • OpenStickiedUnanswered
  • Forum posts: 1

Nov 20, 2014 4:04:45 AM via Website

I've tried all the suggestions for resetting (hard reset) after all the data erased I hit the restart and the frozen x returns. I bought this refurbished from walmart and had it only a month, returns only for 15 days. Any suggestions of anything else I can try? Thank you,

  • Forum posts: 1

Dec 28, 2014 8:10:10 PM via Website

I have previous Nexus 7 wifi model with KitKat

Some days ago I set it on airplane mode. Now when I turn airline mode off and turn on wifi, it restart. When it comes on, it is back on airplane mode.
I have tried to reset it to factory settings from menu and also from the power/volume buttons (force reset). It says that reset is done, but actually it is not- when devise is turned on again, it is still on airplane mode..

What should I do...


  • Forum posts: 1

Feb 22, 2015 7:39:35 PM via Website

Wilfrid Wong


I have tried your method and get as far as "Recovery Mode". Upon selecting this mode, my 2013 N7 restarts into Google logo. I don't get to see the icon with an exclaimation mark. Just stuck at Google logo. Regardless, I tried holding down power while pressing volume up key. The tablet just shutdown. I would like to know if there is anything else I can do. Thanks!

I'm getting the same thing with my Nexus 7 2013. No matter what I select in the bootloader screen I end up at the Google logo indefinitely. I can't get the exclamation point or any option to factory reset. It's been stuck for a couple weeks. How can I reset?? I've tried all of the described ways of hard, soft, or factory resetting. Help!

  • Forum posts: 1

Mar 10, 2015 1:30:35 AM via Website

I bought a nexus 7 back the first part of 2013 it did a system update the other day and had not worked right since. It would keep turning off. So I tried to do a system reboot and now I get a android that says erasing after so long it falls over and has a red triangle with at ! In it.

How do I fix it?

  • Forum posts: 1

May 25, 2015 8:03:17 AM via Website

On a N7 2013, I needed to do a factory reset because Amazon Warehouse sent me the wrong model, Wi-Fi only instead of LTE, and it was going back. Since I had loaded a few things and did an Android upgrade before I noticed the error, I needed to do a factory reset. And my luck, I ran into the "Google" problem while running it with Nexus Root Toolkit. Everything went fine until the reboot, when it stuck on Google. When nothing else worked, I went into Recovery Mode and tried a data wipe/factory reset and cache wipe, but same result. By then, the Nexus was no longer seen by my desktop except in Bootloader mode. So from there I tried NRM again and this time got an error message that I was running 5.1.1, not 5.1.0. Don't know where that came from, since NRM hadn't said anything about it earlier and I never installed 5.1.1. But a rerun of the whole process, twice, still didn't get me to the moving balls. Unless I come up with another approach, it'll be going back as is.

  • Forum posts: 1

May 28, 2016 8:00:42 PM via Website

I have done the resets still locks on google screen. when I go into the hard reset at the bottom where it says lock status-locked. now what?

  • Forum posts: 4

Sep 20, 2016 10:27:49 AM via Website

I'm still using my original nexus; I have followed instructions and completed a hard reset (as above) - device was not booting.

Device will not boot (spinning screen saver icon). When I go back to recovery menu text at bottom of screen reports:

E:failed to mount /cache (Invalid argument)
E:Can't mount /cache/recovery/log
E:Can't open/cache/recovery/log

This seems to mean I can't wipe cache or hard reset.

I'd appreciate any help. I'm pretty much at a loss. Thank you!

  • Forum posts: 4

Sep 20, 2016 10:49:09 AM via Website

Can I do this when I can't get it to load OS?

I don't know how to 'Enable usb debugging' on the device without access to the device's OS?

Nexus cycles between white Google logo and screensaver; it never boots.

  • Forum posts: 4

Sep 21, 2016 5:59:18 PM via Website

Sorry to be a complete PITA; it is a 2012 Asus Nexus 7 (WiFi).

From the 'hundreds' of options how do I tell which is the best factory image? There are quite a few 2013 Nexus 7 images; but I have no way of knowing which is the best/safest option to start with.

I really just need to get a stable system in there it should then update software, I hope!

  • Forum posts: 4

Sep 22, 2016 7:37:46 AM via Website

From the site provided, I am offered:

"nakasi" for Nexus 7 (Wi-Fi)
Version Download SHA-256 Checksum
4.1.2 (JZO54K) Link 25cab35cfc81a7d92679deece485590dd62070882124149295ded95463a1eb4f
4.2.2 (JDQ39) Link 1ed5719bbf2a709f090f8d1da5c3afc62d6fcb381ee2559f130639873e1d7283
4.3 (JWR66Y) Link 201de0b22cac0d5c8d51b249bf85dbe803b9a63b3eb1a7ceea0a4379b81b132c
4.4 (KRT16S) Link 7e5a44631d7f7df7312c52fedd5fdd5ec4a2d94a99d173c8e67865bb267b6cba
4.4.2 (KOT49H) Link f0e49b7a6a4bbe82019a60b919a75c9c18425c869e5de95c8b78fe13c2e00795
4.4.3 (KTU84L) Link 933858800b0fa94d2ee2289506c10065e2be9570852d845fa1732925031e380a
4.4.4 (KTU84P) Link 9482e892e274e27cc18028e82e206b2e9de82f17cd29ea6ab526592e997112d9
5.0 (LRX21P) Link 7d66743ed60fba0d83a44513c7a98e912302fa5c1f5634c33a38a08510f82885
5.0.2 (LRX22G) Link 386f8be2ae4ca68486535130f19eae68c93c59c770ea3e1e2da7b1876a15dd40
5.1.0 (LMY47D) Link 7f853a00ac20643c216e28f220a34c14024404240c9dd5f6002de4f982be8c2c
5.1.1 (LMY47V) Link 5a0bb0593ee9867bee61d59e94462e681c050da9db1397db98616e8887034614

Should I just use 5.1.1?

  • Forum posts: 1

Nov 2, 2016 12:45:17 PM via Website

i have the same problem but with a 2013 model. Did you get your problem fixed in the end?

  • Forum posts: 1

Jan 5, 2017 3:29:22 PM via Website

That worked, Raymond. Thanks for the good advice.

  • Forum posts: 1

Feb 4, 2017 7:43:07 PM via Website

Hello, I tried to do factory reset on my google nexus 7 tab. But when I choose recovery, a android sign comes with an exclamatory sign with a writing 'no command' and gets stuck. I tried with double clicking the power button with volume up button but my tab is just shutting down, nothing else is happening. Can anyone please help me?

— modified on Feb 4, 2017 7:45:55 PM

  • Forum posts: 1

Oct 4, 2017 5:23:09 AM via Website

Thank you, Kris! I've been searching for how to get into my device, as I haven't used it in over a year, if you can't remember the pattern password. Obviously, it's contents were not important if I haven't needed it in the past year.

Anyway....I performed the hard reset w/success!


  • Forum posts: 1

Feb 6, 2018 8:34:38 PM via Website

Kris. My pad was getting flaky. I first tried a factory reset, which left me with a slightly more flaky pad. Then I went for the hard reset. (many times) I also tried clearing the cache. I can reboot and get to the dancing light balls, but never further. A couple of times I left it running overnight to see if it would ever get some where. It never did. Whats next ?

  • Forum posts: 721

Feb 7, 2018 12:19:54 PM via Website

Randy R.

Kris. My pad was getting flaky. I first tried a factory reset, which left me with a slightly more flaky pad. Then I went for the hard reset. (many times) I also tried clearing the cache. I can reboot and get to the dancing light balls, but never further. A couple of times I left it running overnight to see if it would ever get some where. It never did. Whats next ?

Try re-flashing

Ready To Help You.