This app is incompatible with your device.

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Nov 13, 2013 7:54:09 AM via Website

Hi All,
I have Android 4.2.2 device and I want to install an app on that mobile that is supported on and above Android 2.3, but this app is show message "This app is incompatible with your device." on google play account.How to make that app compatible with my mobile.I have Micromax A63 mobile and application name is study section.Please reply...

— modified on Nov 13, 2013 8:57:43 AM

Loie Favre
  • Admin
  • Staff
  • Forum posts: 1,116

Nov 13, 2013 5:09:40 PM via Website

Hi Ajay,

We talked about how to do this in our article which is called ''Install Incompatible Apps with Market Helper''

To break it down again for you, you need to:

  • you must make sure that your device is rooted other the app that we’re going to use won’t work.
  • you must enable “Unknown Sources”. To get these enabled, head to Settings > Security > “Unknown Sources” checkbox.
  • Install Market Helper APK from XDA developer's forum
  • Move the app over to your phone and install it to your device. You can also download it via a mobile browser and install it directly.

To then set up the Market helper, you have to:
  • change the identity of your device or spoof your country location in the Google Play Store by going to change the identity of your device or spoof your country location in the Google Play Store.
  • agree to act as a superuser
  • in 'Select Device', you have specify whether you want to pretend to have a tablet or a smartphone in the Google Play Store.
  • choose what type of device you want to spoof. Because I wanted to try out Facebook Home on my Galaxy S2, I choose to spoof a Galaxy S3.
  • In Select Operator, you set your country, like in the USA for example, and choose AT&T. Then choose Activate.
  • The confirmation allows you to go to the Google Dashboard and update your account.
  • Hit your home button and open Google Play on your device

This should work!