Samsung Galaxy S3 — Wifi Problem

  • Replies:12
  • OpenNot stickiedUnanswered
  • Forum posts: 11

Jan 15, 2014 8:05:24 AM via App

How to resolve the wifi drop issue in galaxy s3?

— modified on Jan 15, 2014 8:05:38 AM

  • Forum posts: 11

Jan 15, 2014 6:45:23 PM via App

Yes..it is dropping at my home...but my other devices like tab 2, do not have this problem..and thanks for replying!!

— modified on Jan 15, 2014 6:46:06 PM

  • Forum posts: 1,077

Jan 16, 2014 10:09:12 AM via Website

Hi Sunny,

Are you trying to connect the Galaxy S3 to the wifi for the first time, or has it worked fine before? I've had a similar problem with connecting my Nexus 5 for the first time to the wifi at home and getting "Authentication problem". My other devices were connected with no issue though.
  • Forum posts: 11

Jan 16, 2014 5:26:17 PM via App

No..for the first few days it was working quite nicely, and one day suddenly after connecting it to wifi, it started disconnecting and connecting continously and the phone restarted itself..the problem persisted even after turning on..all my other devices work fine.
  • Forum posts: 11

Jan 17, 2014 6:54:36 AM via App

After restarting my router, the problem resolves. But it again starts after sometime. Thanks for replying.
  • Forum posts: 2

Jan 17, 2014 12:52:34 PM via Website

Hello mate, have you upgraded to 4.3, if so then its the firmware upgrade that is the problem. I should know cos I'm having the same problem and I'd looked on many forums about this problem and were not alone! It's about time Samsung apologised, but they wont cos they want us to buy a new phone as our phones are now messed up!

I can stand infront of my router and i know it has a strong connection cos my phone tells me this, but it disconnects anyways and in the notification window it saying unstable connection!

This is just one of many problems the new firmware upgrade has given, there are plenty more you might find out like the battery running out faster and so on!

— modified on Jan 17, 2014 12:56:01 PM

  • Forum posts: 11

Jan 17, 2014 8:41:27 PM via App

yeah mate, you are correct. definitely there are many more problems, the primary one being the battery running out. Samsung is creating this mayhem to the most popular smartphone in the U.S, that stuns me. If u find any solution to any of the problems, be sure to let me know. Hope samsung sends a firmware update, resolving the issues.

— modified on Jan 18, 2014 4:26:49 PM

  • Forum posts: 1

Feb 6, 2014 8:42:37 PM via App

sunny and scfi have nailed it on the head. upgraded yesterday to 4.3 and my s3 does exactly the same although I just ignore it and carry on. the annoying bit is the way it makes the pages you are reading unstable. Samsung wont do anything about it cos they are concentrating on kit kat.
Lalit
  • Admin
  • Forum posts: 2,156

Feb 7, 2014 7:25:37 AM via Website

SCi Fi
Hello mate, have you upgraded to 4.3, if so then its the firmware upgrade that is the problem. I should know cos I'm having the same problem and I'd looked on many forums about this problem and were not alone! It's about time Samsung apologised, but they wont cos they want us to buy a new phone as our phones are now messed up!

I can stand infront of my router and i know it has a strong connection cos my phone tells me this, but it disconnects anyways and in the notification window it saying unstable connection!

This is just one of many problems the new firmware upgrade has given, there are plenty more you might find out like the battery running out faster and so on!

I was looking round the forums and seen that previously samsung is having some problems and sources said they have roolled out the firmware again !! I don't know about your region !!
  • Forum posts: 1

Mar 18, 2014 9:00:03 PM via Website

After trying almost every solutions from here and other forum i've finally found a solution for me. First of all my main problem is that my Galaxy S3 did connect to my wifi but not to the internet. I found out that my S3 didnt liked my static DNS IP Adresses that was entered in my router config (provided by my ISP) I changed the primary and secondary one for the DNS of Google which are 8.8.8.8 and 8.8.4.4 after that no more problem, fast and reliable internet on my S3, My PC and other devices which were working before are still working so no downpoint so far! Btw i didnt have any wifi issues on my S3 before the last firmware update so theres definitely something wrong with it.

Hope it'll fix it for some of you!

P.S. sorry for my bad english

— modified on Mar 18, 2014 9:08:02 PM