Play store says "Installed" and won't let me

  • Replies:25
  • OpenNot stickiedUnanswered
  • Forum posts: 1

May 19, 2016 12:57:19 AM via Website

Hi Joel,

Could I ask you - I live and teach English in China :-) I bought my phone in China (a legit and established store), but there are some apps I can't uninstall, like the default internet browser. After turning off 'do not allow unknown apps' (or whatever), I still can't download or uninstall much.

Is rooting one's phone really tampering with it? Could it be a risk? Or no harm really?

I'd appreciate your advice : )
Dean

  • Forum posts: 1

Jun 19, 2016 12:43:58 PM via Website

I had the same problem while using Play Store through Firefox, but when I used the Play Store app everything started downloading.

  • Forum posts: 1

Jun 27, 2016 3:50:09 AM via Website

This is what worked for me. On Firefox, in Play Store the app download was interrupted but it still showed "Installed". Tried clearing the cache, rebooting the phone, syncing my Google account, etc. Finally saw Jon Jonsson's post, went to the Play Store app on my phone and the app downloaded and installed just fine.

  • Forum posts: 1

Oct 7, 2016 6:03:03 AM via Website

I went to the play store on my phone instead of PC and it let me install.

  • Forum posts: 44

Mar 2, 2017 7:05:58 PM via Website

Also you can try uninstall app with adb.

adb shell pm uninstall

Also you can check what apps you have by listing you device /data/app dir with command
adb shell ls /data/app

  • Forum posts: 1

Apr 18, 2017 4:23:51 PM via Website

I finally managed to fix this simply by going to the Play Store on the device and finding the app in the library. It seems that as the install failed, it considered it an uninstall, and hence was listed in the library. I reinstalled from there.