Activating 4G/LTE Samsung Galaxy S4 Active

  • Replies:29
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Jan 15, 2015 12:20:23 AM via Website

I have Samsung 4s 19500 but I wont to know if it work with 4g network because the LTE option does not appear in my option
Model number : GT-I9500
Android : 4.4.2
Baseband ver. : I9500XXUGNF6
KERNAL VER.3.4.5-2434847

  • Forum posts: 10

May 3, 2015 6:46:44 AM via Website

I recently upgraded to android 4.2.2 and 4G LTE was automatically available sans the 4G Toggle app which got deactivated

One comment about the upgrade. The battery drains fast. From another post....I removed both the SD card and SIM and allowed the phone to rest for more than 10 minutes. Then after reinstalling the SD card, SIM and battery, the phone was rebooted and charged to full capacity. The phone is now cool and behaving normally.
Though recommended I did not do a factory reset

  • Forum posts: 1

May 31, 2015 10:28:00 AM via Website

Hi, I can't find any mister31 solution? When I Google "admin edit: links are forbidden" can u just paste the solution plz?

  • Forum posts: 2

Sep 4, 2015 11:01:18 PM via Website

ian gillies

had a look on ebay mate and it says its LTE witch is different from 4g I think

  • Forum posts: 2

Sep 4, 2015 11:04:40 PM via Website

ian gillies

Hi everyone!

This may seem quite simple, but many beginner Android users are having trouble with this.

To be able to take advantage of the 4G network, you need to activate the 4G settings beforehand. Here are the steps:

Once you are on the home screen of your device, tap on the settings button.
Next select More settings.
Then go to Mobile networks and select Network mode.
Here check the box for LTE/GSM/WCDMA (auto-mode).

Now your 4G network has been activated!

Do you have any further questions or problems?

Forum Rules - Recommended for new AndroidPIT members! Important to all community members: please read before posting

  • Forum posts: 1

Dec 30, 2015 7:15:00 PM via Website

The problem in my phone is that, when I open the settings>more networks>mobile networks> I don't have the network mode settings. That is why I don't know where to activate my 4G LTE. Everytime I use my mobile data, I am stucked with the 3G network. I have read somewhere about the LGUHiddenMenu of my phone and enter that. But they say that I must activate LTE B3. But in my option, it is only B1, B5, B7 and LTE ALL. :( Please help me. :(

  • Forum posts: 1

Apr 4, 2016 3:37:47 AM via Website

I chose the one that says CDMA/LTE/EVDO and it still not connecting

  • Forum posts: 1

Jul 3, 2016 5:43:16 AM via Website

Thanks it real work

  • Forum posts: 1

Sep 8, 2016 8:57:43 AM via Website

what is the press option .i cant find it