Failure of Samsung Galaxy S3 Reboot.. Please help.. My phone stuck at SAMSUNG (it is just flashing there)

  • Replies:61
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Feb 6, 2016 1:40:21 PM via Website

Scott same prob with me but when.i prest 3 keys u mentiond but nothing happens.fectry data reset option comes for a while after 2 3 sec it gone.then samsung logo stucks tell me what i do.plz help me sir

  • Forum posts: 1

Feb 15, 2016 9:43:23 AM via Website

I had the same issue. I simply wiped my cache 5 times. Then immediately did the factory reset. It worked beautifully.!

  • Forum posts: 1

Mar 25, 2016 11:44:43 AM via Website


will delete all user data (deletes the data from my external sd card too ) . Please reply asap.


  • Forum posts: 1

Mar 30, 2016 1:45:17 PM via Website

I know im a bit late. But for the third step do i let go of the power button after the vibration and then let go of the volume up and home button when i see the android logo?

  • Forum posts: 1

Apr 2, 2016 10:45:56 AM via Website

Hey there, if you are having this problem then I can tell you the fix. Me too experienced the same problem but I somehow managed to get rid of this problem. Now all you have to do is flash the recovery file for your samsung android using Odin. You can read all the steps and follow them very carefully from this tutorial that you can find by Google "fix samsung galaxy stuck at samsung logo kickiteasy" then you'll also have the fix.

  • Forum posts: 1

Apr 12, 2016 5:24:51 PM via Website

I awoke up in the morning and found that my phone was dead. I tried to turned on and can see only "SAMSUN GALAXY S3 GT-I9300" and remains here for ever.

I tried to enter in RECOVER MODE and it gives me error "E: UNABLE TO MOUNT /efs" Unable to mount /system etc etc and whole screen is covered with this MOUNT errors.

I tried to put it in download mode "Down volume key + Menu + Power key", computer can see a device is connected but unable to connect with phone using KIES, ODIN and ADB shell.

Can someone help me to solve this problem?



— modified on Apr 12, 2016 5:25:46 PM

  • Forum posts: 1

May 4, 2016 9:02:57 AM via Website

Some moments i found my phone is dead(SAMSUN GALAXY S3 GT-I9300)I try to all option to turn on but still no updates,Then my display showing Downloading... like this.How can i recover my phone.

Help ,if u can possible

Thanks & regards,
Sagar Sunny

  • Forum posts: 1

May 6, 2016 7:39:35 PM via Website

there are some apps that won't be removed even with that kind of wiping or any kind for all i know>one of those is (APUS) and some others. and the biggest problem is that after i wiped every thing an other problem came up (the touching option is gone after 10-15 sec)
So Please!!!!
Help me Man......

  • Forum posts: 1

May 28, 2016 10:36:38 AM via Website


my phone is samsung J2. Recently, i dropped it. I wanted to unlock my phone password after on-ing the phone but it cannot detect. So i shut down and tried to on it back but it was stucked at the samsung logo. I tried to factory reset by pressing the necessary buttons but to no avail. Please help me!!! :/

  • Forum posts: 1

Jul 12, 2016 2:37:01 AM via Website

Hello I have tried to reboot my Samsung galaxy s3 mini I've tried the volume up an home key an the power it don't vibrate all the phone does is show the logo I'd what to do idk if it matters but all the phones I've seen the power button is on the side mine is on the top?? Plz help

  • Forum posts: 1

Aug 7, 2016 7:29:52 PM via Website

I know this is a very old post but, I'm so glad it was here! Thank you sooooo much for this advice. My husband messed his phone up and was throwing a fit (like a little kid). However, he's phone wouldn't get past the (T-Mobile) insignia after he tried to do a factory reset while in developer mode. So I did what you suggested here (just to see what would happen). Nothing, tried again and again saw a little glimmer of hope but, then I asked it to send a file and poof it sent a upgrade and now he has he's phone back. Thanks so much for your advice it was so helpful. :-)

  • Forum posts: 1

Aug 14, 2016 6:43:08 AM via Website

hi satish

i just try what u said...but my samsung keep stuck on that samsung logo

  • Forum posts: 1

Sep 21, 2016 12:53:03 AM via Website

hey scott, but i cant move my volume, it just selects the reboot option but i cant put it back to factory settings. what do i do if volume wont work?

  • Forum posts: 1

Nov 22, 2016 2:47:55 AM via Website

I have the same problem as well, and the factory reset did not finish properly, can you please elaborate the steps after? thank you so much

  • Forum posts: 1

Dec 16, 2016 2:33:03 AM via Website

I wiped the cache a bunch of times in a row and then rebooted! That did the trick.

  • Forum posts: 2

Dec 16, 2016 2:41:17 AM via Website

You should try to turn it off and then turn it on again. if it still doesn't work, ask for a technician or have your phone rooted.

  • Forum posts: 3

Dec 26, 2016 1:30:11 AM via Website

I gave the phone to my daughter to research and factory reset it which she did, but now it won't start and just shows Galaxy s3 logo and does not go any farther. I followed your instruction but mine does not get to the Android logo no matter how long I hold all three keys!
It is a freedom pop phone and it got sold and I need to ship it now but this would be embarrassing now. :(
Can you help me?

  • Forum posts: 3

Dec 26, 2016 1:42:14 AM via Website

when i went back to reboot it says your device does not appear to be rooted. install superSU now? this will root your device.
what should I do?

  • Forum posts: 3

Dec 26, 2016 4:06:52 AM via Website

Actually this phone seems different maybe it's because Freedom Pop phone! But I did what you said finally but it goes to some kind of safe mode I think, the touch screen still works but when I hit reboot it says "no OS installed are u sure?"
not sure what does that mean.