Are the apps develop using android 5.0 (API 21) works in phones with older version of android?

  • Replies:6
  • OpenNot stickiedUnanswered
  • Forum posts: 7

Nov 13, 2014 9:02:12 AM via Website

Are the apps develop using android 5.0 (API 21) works in phones with older version of android?

Cause I am developing my first android app. So yeah that is my question.

  • Forum posts: 118

Nov 13, 2014 10:03:55 AM via App

Not really unless you use backwards compatibility but you cant use all features within api 21. You could google appcompat 21 pre lollipop for great tutorials.

  • Forum posts: 7

Nov 13, 2014 10:39:58 AM via Website

So it means that..

If I create an app in Eclipse IDE using Android 5.0 API 21 and I will use it on a phone with Android version of 2.2 I can't use the app?..

Or it is ok if I use Android 4.4W and lower?..

Cause you know in the Philippines not all Android users have the latest Android version...

  • Forum posts: 118

Nov 13, 2014 10:56:28 AM via Website

Jay Angue

So it means that..

If I create an app in Eclipse IDE using Android 5.0 API 21 and I will use it on a phone with Android version of 2.2 I can't use the app?..

Or it is ok if I use Android 4.4W and lower?..

Cause you know in the Philippines not all Android users have the latest Android version...

Exactly, you can't use the app on your phone if you develop it only for API 21+ and wish to use it on lower versions of Android.

Take a look here: https://chris.banes.me/2014/10/17/appcompat-v21/ It uses the support library v7 to still create a toolbar which looks really nice and is originally used in API 21. But if you're new to Android app development, I personally recommend you to develop an app for API 21+ regardless of whether someone else could run it or not. If you're done developing the app ( I suggest you not to create a huge app as beginner ) and use the support libraries as backwards compatibility to let the app run on previous versions. Android 2.2 is really old and people barely use it. To people who do, I recommend them to update their OS as soon as possible or buy a new phone. Lots of apps don't even support 2.3 and below.

If you used to be in web development like me, you will know that creating webdesigns is like the same. In IE8 it looks so different than in IE9 when IE8 is much older than IE9 but people still seem to use it.

Don't go lower than android version 2.2 (I think that's API 8), it's not worth the trouble.

  • Forum posts: 11

Nov 17, 2014 5:25:34 PM via Website

There's something called a target SDK version and a min SDK version. The min SDK version is the minimum android version your app will support. The target SDK is the version used to compile your app. So if you min SDK is 14 and target SDK is 19, your app will still run on Android API level 14+ devices.

  • Forum posts: 11

Nov 18, 2014 8:58:42 PM via Website

You can also find this on the Google android site:
I can't link yet since I'm new, don't know when I can. But just google android versions dashboard.

Which helps you to decide how old a version to support. You can get almost 90% of the market with 4.0+.

Deactivated Account
  • Forum posts: 16

Feb 4, 2015 11:02:26 AM via Website

Yeah ..
I can use it in my phone with updated version.