So it means that..
If I create an app in Eclipse IDE using Android 5.0 API 21 and I will use it on a phone with Android version of 2.2 I can't use the app?..
Or it is ok if I use Android 4.4W and lower?..
Cause you know in the Philippines not all Android users have the latest Android version...
Exactly, you can't use the app on your phone if you develop it only for API 21+ and wish to use it on lower versions of Android.
Take a look here: https://chris.banes.me/2014/10/17/appcompat-v21/ It uses the support library v7 to still create a toolbar which looks really nice and is originally used in API 21. But if you're new to Android app development, I personally recommend you to develop an app for API 21+ regardless of whether someone else could run it or not. If you're done developing the app ( I suggest you not to create a huge app as beginner ) and use the support libraries as backwards compatibility to let the app run on previous versions. Android 2.2 is really old and people barely use it. To people who do, I recommend them to update their OS as soon as possible or buy a new phone. Lots of apps don't even support 2.3 and below.
If you used to be in web development like me, you will know that creating webdesigns is like the same. In IE8 it looks so different than in IE9 when IE8 is much older than IE9 but people still seem to use it.
Don't go lower than android version 2.2 (I think that's API 8), it's not worth the trouble.