Samsung Galaxy S5 Active — webrtc p2p black screen

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Nov 24, 2014 4:34:07 AM via Website

November 23,2014

I need your help.

I wrote a WebRTc program following the Youtube tutorials and working with github,,, and others.

I uploaded the p2p code to my website It works great.No problems with the desk top Sony or portable lap top Mac Book Pro operating Window 7 and completed a p2p communication.Video as well as the audio functions worked without a delay in timing.

I ran the Firefox,Opera,Chrome browers using windows 7 on the desk top computer. All 3 browers were update to the newest revision.

What I am getting on both computer and android Samsung Galaxy S5 is that the cameras are working on both and next to the video screen are black blank screens 1/3 the size of the video screen.My images on both video screen,from the cameras operating from their own device, have no time delays.This is when I call(Using Peerjs PeerServer Cloud API keys) either from the smart phone or the computer

The android Samsung Galaxy S5 will not download Firefox nor Opera,I have only Chrome to use as a browers, and that has been updated chrome Beta 39 Version 38.0.2125.111 m
I need some advice on working with the android on a Samsung Galaxy S5 Sport smart phone.

I tried it on the Samsung testing it using both the desk top and the lap top computers and both cameras are turned on in their system as well as the Samsung camera is activated.I tested it with the lap top and then the desk top computers,

but the video connection on both creates a black blank frame next to their activated cameras in their system and my indicator display states they are communicating with each other.

I am now reviewing the px size and frames per second in the code and the specification in the Samsung manual.The Samsung is 2 weeks old and it does use the VP8 video system.

I am using Peerjs key ID and for the setting in the html section.

Also checking my .js and .css section.

My question is ,have you every encounter this error ?

Any suggestion would be greatly appreciated.

Thank You,

David Brown