4G LTE option missing in Samsung Galaxy S4 i9505

  • Replies:2
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Dec 28, 2014 4:47:30 PM via Website

Got S4 bought in Poland. Use it in Lithuania, which is next door to PL. Unfortunately it got 4G LTE option missing in "network mode" menu. Got USIM and 4G network coverage at my place but cant use it.
Terribly unhappy :((((
Any ideas, guys?

  • Admin
  • Forum posts: 2,138

Dec 28, 2014 4:57:37 PM via Website

Well, @Xado now that's sad anyway I think I have a trick to help you out :) But yes don't mess up things by experimenting on your own (danger) follow as I guided you over here,

Try going onto service mode by dialing *#0011# >menu back>menu key input 1 >menu back > LTE > Pref mode set > change to GWL and reboot.

Now what will happen over here is you will not see the option in the settings but your device will connect to 4G when available ! :D Also let me know how things goes !

  • Forum posts: 2

Dec 28, 2014 5:33:52 PM via Website

I do what u say but can get through to the LTE step. Dial numbers, than hit menu button and press"back" (nothing changes on the screen), than hit menu again and "key input", please enter value -> enter "1". Than menu button and "back". No changes on the screen again. No LTE option.

I i saw that fixing option on the net but it didn't help. Don't want to go for the option2 as don't trust "rooting" thing. Many say got too many problems after.