Samsung Galaxy S5 — WiFi wont turn on after Lollipop Update

  • Replies:42
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jun 5, 2015 2:55:09 AM via Website

hi, Im a galaxy s5 user.
my wifi has a very same problem with you.
If you fixed your problem without reseting your device would you share your experience please?

  • Forum posts: 1

Jun 15, 2015 10:08:09 PM via Website

Matthew Palazzola


Recently, about 2 weeks ago, I updated my software to Lollipop and had no issues with my wifi connection. Due to battery drain I attempted a Settings Reset which did not fix the issue. I did not want to try a factory reset at the time.

Shortly after the Settings Reset, I ran into the current problem I am having. My WiFi wont turn on at all. It permanently remains off. In the WiFi screen itself the bar remains on off, though I can drag it to the on side, but it will not stay or turn green. It remains gray when I drag it.

There is the same problem with the quick access menu. I can highlight the button and it will look green, but as soon as I move my finger it changes to gray. It will not connect at all. I had read about possible solutions for the same issue on older operating systems and thus far have attempted the same setting reset, pulling the battery, booting in safe mode, and also using the cache wipe. Nothing seems to have fixed the issue.

I also read that a factory reset "may" fix it, however there was no guarantee. As I don't want to lose any settings or information, including call logs, text messages etc, I don't want to do a factory reset if it wont fix the problem for sure, or if the problem will come back. Is it possible an update is coming to fix this? Has anyone else encountered the same problem?

Any help is much appreciated.


* I accidentally posted this on the Active forum when I meant to post it here. I am using a Verizon Phone.
I had the same issue and had to do the settings reset twice and it worked . Not factory reset just settings reset. Good luck

  • Forum posts: 1

Jun 16, 2015 12:52:29 AM via Website

I have the same problem as everyone else on this forum. Galaxy S4 on Verizon worked fine until Lollipop. Then after updated to lollipop via my home wifi - so it was working just fine. Immediately after updating, my phone won't connect to my home wifi. It It repeatedly tries to connect (says, "Connecting ...") but it never actually connects. It then says "Saved, Secured" under my home wifi network name in the Wi-Fi settings on my phone.

I have tried resetting the phone (including by removing battery), resetting the router, resetting the modem; toggling wifi on/off; toggling airplane mode on/off; resetting router to factory settings; and pretty much everything else. The wifi connection works on all my other devices so the modem & router are working just fine.

When might the Gods that be provide a fix?

p.s. Everyone I know with a Galaxy S4 or Galaxy S5 are having the same wifi issues and so far, the only fix has been to purchase a NEW wireless router.

  • Forum posts: 1

Jul 2, 2015 1:56:11 AM via Website

Eric Flowers

If you have an SD card installed, remove it and restart your phone. Hope this does the trick. Sucks, but it's the only thing I could find that will work.

Hi guys, I have tried a lot of the tips you gave in this blog, and the only thing that works was removing my SD card and restarting, WiFi starts working again.

  • Forum posts: 1

Jul 22, 2015 9:43:20 PM via Website

Hey guys, been having the same kind of problem with my wife's phone. Tried factory reset, tried clearing the cache, tried going to settings and using the "WiFi Help" just to be sure... her wifi doesn't even turn on.

When I tap the WiFi tab to turn it on, it doesn't move and in the WiFi connections area it just says "Turning on..." and doesn't.


And then...


Any ideas?? Thanks in advance guys..

  • Forum posts: 1

Jul 26, 2015 6:01:23 AM via Website

Just wanted to thank you Eric Flowers! To remove the SD card was the solution for me. I brought it twice to service. Now it's the third time this happens and I don't live in the country anymore where i bought the Galaxy Tab S 10.5. Removing the SD card did the job. Great input there!

  • Forum posts: 1

Aug 1, 2015 4:45:24 PM via Website

Ok yesterday my wifi was connecting unconnecting and then reconnecting again every 30 seconds. So read forums and found settings reset and to unplug the modem and back in. It worked. However last night I charged my phone and woke up today found I was only on mobile data. Tried turning on wifi but it didn't work. Cleared cache, ended processes, shut off my phone and back on and power reset. No luck. Came across this forum and tore off my otterbox, reset the settings again and tore out the battery and sd card and put it all back in to reseat everything and so far I'm connected to my wifi again. Thanks for the help. Lollicraps a joke. Nothing but negative feedback.

  • Forum posts: 1

Aug 11, 2015 12:09:45 AM via Website

i just made an account to thank you.finally it worked .I had this problem for about two months. it started after that damn lollipop update .well done Samsung.

  • Forum posts: 2

Sep 5, 2015 7:04:29 PM via Website

I too have created an account just to THANK you.

Thank you, Eric

  • Forum posts: 1

Sep 6, 2015 9:31:12 PM via Website

Eric!!! thanks so much, also registered only to say Thanks!!!!!:)

  • Forum posts: 1

Sep 18, 2015 10:07:50 AM via Website

I solved it
I tried all solutions above. But In my case, simply turning off the GPS solved the problem
I hope it will work for you too

  • Forum posts: 2

Sep 30, 2015 3:22:24 PM via Website


Does anyone have a definitive solution?
The SD card trick worked for me at first.
Then I had the same issue and this trick would not work.
Next, I just turned on my phone off and on again several times then after like 20 trials, I was called up and went away to come and find that the wifi was working again.
I am habing the same issue again; only that it is both the bluetooth and the wifi now.

Does any one know what the problem truly is and how to fix it?

  • Forum posts: 15

Oct 10, 2015 8:02:17 AM via Website

It must be a bug. Following steps works for me

Go to recovery mode
Wipe cache/ delvik cache
Wipe data to factory reset
Backup sd card and format sd card.

  • Forum posts: 1

Feb 12, 2016 9:37:09 PM via Website

I two have and S5 and had the same WIFI problem, so I tried to shut down my cell and when the screen came up I thought I would just try the restart, and when it rebooted, behold it was and still is working fine! Hope it works for you as well good luck!!

  • Forum posts: 1

Feb 18, 2016 5:34:40 AM via Website

This plagued me on galaxy s5 for a whole month.Bought phone with 4.2.2. on it.Bluetooth wouldn't stay and wifi stayed light green.Just took to bestbuy to Samsung experience shop and they updated it to lollipop. (2/17/16) After they upgraded the software , Bluetooth would stay switched to on but it wouldn't scan or anything. WiFi just still stayed light green.What I did was took device home and set the Bluetooth toggle switch to on and hit the phone on the backside to the right of the camera right next to the volume up or down with the palm of my hand.Then suddenly Bluetooth actually started searching and connecting to my other devices.So at that moment I still had no WiFi so I just popped the battery out(while device was still on ) removed sim,SD card and powered it back on holding down home,power,and volume up key.A screen should come up with one option to clear cache partition. CLear it maybe 6 to 10 times then choose the option to boot normally. After this my WiFi started to fully turn on.So afterwards I turned phone off reinstalled sim,SD and it's still working.Was without WiFi and Bluetooth on this phone for a full month and a half so this definitely works.

  • Forum posts: 1

May 2, 2016 12:19:33 PM via Website

Don't know if this'll work for everyone but this happened to me, exactly the same problem as described. What I did was plug my phone into PC and run Samsung Keis, there was an update there that seemed to have a patch for this bug because after the update I rebooted my phone and the problem was fixed. Hope this helps some if not everyone.

  • Forum posts: 1

May 10, 2016 12:25:13 AM via Website

I tried ALL of the above, including removing the Memory card.. NOTHING worked...... THEN..Out of Frustration, I removed the SIM card too...

I put the battery back in, turned it on with NO SIM or SD card.. and it WORKED!!!!!!!!!!!!!!!!!!

Hope it helps! :)

  • Forum posts: 1

May 11, 2016 2:43:39 PM via Website

This is a funny issue.

Fixes mentioned in this thread:

  • Remove SD card, reboot
  • Remove SIM card, reboot
  • Wipe cache + dalvik cache
  • Factory restore / settings reset
  • Downgrade / upgrade / rom re-flash
  • Flash kernel
    ^--- OK, this is what I found worked for me.

I lost WiFi after flashing modem via Odin on stock LL. Ended up with custom recovery and rooted device as a preparation for custom rom, but flashed just the kernel out of curiosity and WiFi came back!

  • Forum posts: 1

May 31, 2016 10:45:36 AM via Website

Hi My wifi came back after I restart by taking out the SD Card. However when I put it back it doesnt read the card anymore.

Pls help. Tyvm.