Samsung Galaxy S5 — WiFi wont turn on after Lollipop Update

  • Replies:46
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Aug 21, 2016 7:39:08 AM via Website

Removing the battery and putting it back will always fix the wifi. If it does not fix it then remove the SD card too. Put the battery back without the SD card and turn on the phone. Your wifi should be working.

If it is after an update this will not fail to work

— modified on Aug 21, 2016 7:41:36 AM

  • Forum posts: 1

Aug 30, 2016 5:21:40 AM via Website

I did my best, but I guess my best wasn't good enough!! One day old Samsyng A7 phone and yet Im having an issue connecting to WIFI, makes me nuts! Tried everything, but no luck, I will going to return this shit to the mobile shop ang get my money back! I guess Samsung is one hell of a crappy phone.

  • Forum posts: 1

Nov 11, 2016 3:14:27 AM via Website

Guys I had this problem and solved in minutes with a very easy step, just installed google now launcher and wifi came back to normal like magic.

  • Forum posts: 1

Nov 17, 2016 11:09:46 AM via Website

Found a workaround that I have not seen mentioned above. Created an account just to share, because I know how frustrating this bug is!

So yeah my Wi-Fi icon in quick settings also keeps blinking on and off every few seconds.

Things I tried that DIDN'T work:

  • removing battery
  • removing MicroSD card
  • (un)checking Smart network switch
  • updating to Marshmallow (6.0.1 - via PC because no wifi :( )
  • YouTube video 'Fix Samsung Galaxy WiFi problems!!! - Howtosolvei' (no 'ON' button)
  • prayer

Workaround that DID work, and has worked repeatedly:

  1. long press Wi-Fi icon in quick settings
  2. tap menu icon (3 dots in top right corner)

image

  1. tap Help
  2. tap Turning Wi-Fi on or off
  3. tap START NOW and wait a few seconds

--> the list of available networks will appear and a wifi connection will be established. You may have to repeat 5. a few times before the list appears!

This won't permanently solve the problem. You will probably have to do this again every time you turn wifi back on after you've had it switched off for a while. It is a pretty quick workaround though.

I hope Samsung addresses this issue shortly, and in the meantime, I hope the above helps.

  • Forum posts: 1

Dec 12, 2016 10:56:49 PM via Website

To clarify the above, which worked beautifully for me, I had to pull the SD card only once. When the phone restarted, WiFi hiccuped on the first try to turn it on, but came on and stayed on after that. I shut the phone down, re-inserted the SD card, started back up, and all was still well. Thanks for the tip, Eric. I did not want to go through all of the resets and gyrations others had mentioned. Glad I tried this first. Note: this was on an S5 Active.

— modified on Dec 12, 2016 10:58:09 PM