Samsung Galaxy S5 — T-Mobile Galaxy S5 (SM-G900T) Firmware

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 1

May 22, 2015 8:11:21 PM via Website

I read the article regarding downgrading from Lollipop back to KitKat, but the link which provides the correct versions of KitKat based on carrier does NOT include T-Mobile. Is there some other way I can determine what I should use? I can't STAND Lollipop and I don't have the patience to wait for any corrective updates that may or may not be forthcoming. Any help would be appreciated! Thank you.