Motorola Moto E — HELP : UNABLE TO ROOT MOTO E XT1023 WITH STOCK ANDROID 4.4.4 KITKAT

  • Replies:3
  • OpenNot stickiedUnanswered
  • Forum posts: 25

Jun 25, 2015 8:45:19 AM via Website

HELP : UNABLE TO ROOT MOTO E XT1023 WITH STOCK ANDROID 4.4.4 KITKAT

I have been trying to root Motorola Moto E XT1023 which comes with a standard stock Android 4.4.4 KitKat.

I have tried many ways. I have been able to unlock the boot loader and able to copy and paste various variations of the SuperSU zip file to the root directory of the phone and to unzip this file with TWRP recovery and or with CWM recovery ( have not tried stock recovery yet but I am not sure whether I have 4.4.4.KitKat stock recovery image ).

Anyway, the zip file unzips and gives all standard messages as per the YouTube videos. I have noticed, in some installation, when the SuperSU got unzippes, there is a missing line : " SETTING PERMISSIONS ". I have also noticed the " PARTITION MISMATCH " message when TWRP recovery is written. However, I have seen people also having this on YouTube and their devices rooted perfectly.

I guess, the final goal of the rooting process is to install SuperSU which I have done in many different ways and many different versions. Regardless, although SuperSU installation says " SUCCESS ", I DO NOT HAVE THE SU ICON IN THE GENERAL APP LIST AND VARIOUS ROOT CHECKERS REPORT THE CELLPHONE HAS NOT BEEN ROOTED.

I WONDER WHETHER THERE IS SOMETHING ELSE I HAVE TO DO TO SETUP THE SUPERSU AFTER UNZIPPED. OR DO I USE WRONG VERSIONS. WHICH IS THE CORRECT VERSION? which IS THE CORRECT TWRP VERSION?

I have also tried to use the popular batch installers ( version 2 and 3 ). The same result.

I have also tried to use mfastboot V 2 for everything. Also tried the general purpose fastboot for everything. The same result.

I have not slept for 2 nights because of thie problem with the inability to root the cellphone, something which normal people with normal Moto E XT1023 do on YouTube for less than 30 minutes.

PLEASE, HELP!

  • Forum posts: 25

Jun 27, 2015 3:27:49 AM via Website

PROBLEM SOLVED!

USED THE BATCH SUPER UTILITY V 3. I THINK WHAT HAVE HELPED WAS TO DO A FACTORY RESET AFTER THE TWRP REBOOT. FACTORY RESET REBOOTS AFTER PREPARING THE SYSTEM. THE TWRP REBOOT DID NOT DO MUCH BUT THE REBOOT OF THE FACTORY RESET THEREAFTER DID. TWRP DID SHOW UP AFTER THE FACTORY RESET REBOOT AND INSTALLED SOMETHING.

  • Forum posts: 25

Jun 29, 2015 8:28:28 AM via Website

This is true. Yet, there are many features a rooted phone can have. Also, I am not sure whether the technicians can do more than what is already available online. Also, because there are so many devices and so many apps which may create problems, a technician may simply try the general procedures and, in case of a problem, a technician may not want to resolve the problem as there may not be any specific knowledge and a long while may be required to achieve success. Technicians may not wish to spend so long.

Regardless, you are right : best to ask a technician first.