Lenovo Problems?

  • Replies:18
  • OpenNot stickiedUnanswered
  • Forum posts: 12

Aug 18, 2015 2:43:49 PM via Website

I tried to root my phone yesterday without educating myself on it first (foolish move). Well, my phone has become a brick. Now, that being said, I can access the Lenovo recovery menu (volume up, volume down, and power button), and some other Chinese menu that makes no sense whatsoever. It will start up to the welcome screen, and allow me to "set up" my phone, only to freeze at the "now you can use your new phone" screen, and restarts. Now, it's sitting on the 'android' screen, and the word itself will glow/light up constantly.

To be frank, I don't know much about phones, at all. This is my second android (My first was the Asus Zenfone 6). Prior to this, I was an Apple fangirl.

Even though I can use the phone as I mentioned above, my computer won't recognize it. I haven't attempted to plug it in when it comes to the "Welcome" menu before it freezes, but I will the next time I can get it to load.

androidxda. com/how-to-root-lenovo-k3-note
This is what I used. The first step worked fine, but when my phone reset after trying to replace the chinese applications with SuperSU, it bricked (I'm assuming that's the proper term for my foolish mistake).

Can any one help me?

  • Forum posts: 12

Aug 18, 2015 2:58:05 PM via Website

Sorry, I have a Lenovo K3, K50-t5

  • Forum posts: 1,309

Aug 18, 2015 4:14:24 PM via Website

Did you try to get stock rom and flash it again?

Here you have a link to a gizchina tutorial


You can start from Flashing of the original stock ROM

  • Forum posts: 12

Aug 18, 2015 6:47:15 PM via Website

I haven't tried this yet, but I'm about to. Thank you!

  • Forum posts: 12

Aug 18, 2015 8:03:14 PM via Website

So, I gave this a try, and now my phone won't turn on. It will vibrate when I attempt to get to the recovery menu, but that's as much as a response as I get. It just vibrated again without me touching it. I feel like I've been left with a paper weight now. Am I right?

  • Forum posts: 12

Aug 18, 2015 11:06:06 PM via Website

The process itself worked, and I had no problems with the flash tools. But when I had to do the second step with the flash tools, my phone wouldn't turn on. Now, it won't even display the Android logo

  • Forum posts: 12

Aug 18, 2015 11:26:06 PM via Website

Not anymore, no

  • Forum posts: 12

Aug 18, 2015 11:28:23 PM via Website

The phone vibrates when the power button is pressed, and that's it

  • Forum posts: 12

Aug 19, 2015 5:46:28 AM via Website

I really appreciate your help! I'm going to try to follow the video, wish me luck :)

  • Forum posts: 12

Aug 19, 2015 6:29:00 AM via Website

I've managed to get it to turn back on again! the process went smoothly. It is taking a while to turn on, but I'm not going to rush it this time. Hope this fixes my problem

  • Forum posts: 12

Aug 19, 2015 6:29:33 AM via Website

Aha, I guess I spoke too soon! My phone is running again! Thank you so much for your help :)

  • Forum posts: 7

Aug 19, 2015 8:17:38 AM via Website

This thread is very informative ^^ Thanks! Anyway I have an old model of lenovo, its A369i Question how can i root it?

  • Forum posts: 1

Oct 27, 2015 7:51:52 AM via Website

Hi Lago,

I Have same problem with Lynne. My device is brick now, only vibrate when push on start button, and left the black screen.
If I connect to the USB on my laptop/pc, will come the "Lenovo" logo and a small word in the lower left corner of the screen: "Tool DL Image Fail!.
I Purcharse this phone last week. The Device come with the latest version firmware (I know from OTA update). But the firmware not support multi language (Only CN/EN) and not support google apps. I try to flash this phone with firmware that I found on internet (with SP Tool v5.1516). After finished the download process, I turn on the phone and It was brick (only vibrate and black screen). Too bad I did not make any back up of my device.
I have tried flashing with several rom that i found on www.needrom.com, but still not make it.
I found this thread and learned that Lynne have the same problem with me and she make it (her phone running again). But still the result is nil.
I try with Windows XP and Windows 7 (both run on 32 bit), or I need to run on 64 bit windows?
Do you have any Idea to help me on this issue?
Thank You for your kind assistance.