Samsung Galaxy Note 2 has 100's of contacts I never entered!

  • Replies:5
  • OpenNot stickiedUnanswered
  • Forum posts: 5

Dec 26, 2015 6:21:00 PM via Website

The Contacts of my VERIZON service Samsung Galaxy Note 2 has exploded with contacts I've never entered!

Most of them are just email addresses.

Many are "info@..." or "support@..."

  1. How to edit and get rid of them?

  2. How to turn this off?


Deactivated Account
  • Forum posts: 271

Dec 27, 2015 4:26:01 PM via Website

You will have to edit or delete it manually, nothing could be done regarding it.

Looking for security app? Try Leo Privacy Guard 3.0.

Join Our Christmas Contest by visiting our Facebook page LEO Privacy Guard

  • Forum posts: 664

Dec 27, 2015 5:02:03 PM via Website

Go to Contacts >> settings >> contacts to display >> choose phone number only ..

Ready To Help You.

  • Forum posts: 5

Dec 27, 2015 8:38:29 PM via Website

@ Sanjai Joseph

Thank you.

Yes, that is part of the solution.

I spent 2 hours on phone yesterday with a Verizon Supervisor
over the course of 3 phone calls, as he got back to me after
checking with his Senior Tech staff. He was as perplexed
as I was in the beginning.

Here's what we came up with:


  1. Press: Phone > Contacts > Press lower-left of phone > Settings > Contacts to Display:
    Checkmark "Only contacts with phones".

  2. Press: Phone > Contacts > press lower-left of phone > Contacts to Display:
    Here you can set up what contacts to display based upon the various
    app's you've downloaded.
    In addition to "All Contacts," "Device," "SIM," and my gmail-email accounts,
    I have "WhatsApp," and "GeeVee."
    "WhatsApp," and "GeeVee," have their own contact lists that were populating
    my Contacts by the hundreds.
    At the bottom of "Contacts to display" in "Phone > Contacts > Press lower-left of phone > Contacts to Display"
    is an option called "Customized list" with a gear icon to the right.
    Selecting the radio button next to "Customized list" and then pressing
    the gear icon takes you to a list where you can customize what you want
    to show in your Contacts list based on the various options presented.
    For me I turned off all contacts, for all apps, except for "Device" and "SIM".

  3. I went into my wireless account in Verizon and edited my Contacts.
    I had to go through the 794 contacts there and select each one for
    Then I sync'd my online, Verizon Contact list, back to my phone from
    my Verizon online account, and it reset my phone's contact list to the
    edited version from online.
    Checking my phone's contact list today, all is well: there are no more
    "unknown's", no more "info@..." and no more "support@..." contacts.

I did all the above yesterday, backed out, went back in a few times to make
sure the settings "held" and they seem to be held.

Today when I checked back ... everything seems to have held, but I'm not
100% certain yet. I'll give it a few more days before I know that these
settings have held and I'm no longer getting contacts added to my contacts
that I didn't put there!


  • Forum posts: 5

Dec 27, 2015 8:39:28 PM via Website

@ Roger Moore:

See my above post :)

  • Forum posts: 5

Dec 27, 2015 8:41:14 PM via Website

@ Roger Moore:

There's ALWAYS something that can be done about everything! ;)

Defeatism ... is not an option! :)