Receiving error while installing Android studio

  • Replies:8
  • OpenNot stickiedUnanswered
  • Forum posts: 4

Jun 2, 2016 1:06:24 PM via Website

I am getting following error when installing Android Studio:

"the following sdk components were not installed: android support repository"

I am running Mac OS X El Capitan.



I tried it a couple of times over past couple of days thinking that it might be my internet connection issue. Also tried re-installing the Android studio.

Thanks for any help that you can provide.

  • Forum posts: 256

Jun 2, 2016 1:22:49 PM via Website


Is there enough free space on your hard drive? The installer can not unzip allready downloaded repo.

  • Forum posts: 4

Jun 2, 2016 1:32:21 PM via Website

Hi Vladimir,

Thanks for the reply. Yes, I have around 80GB of free space.

  • Forum posts: 256

Jun 2, 2016 2:08:26 PM via Website

You can try this:
Go to My tools/ and run:

android update sdk -u

The studio will pull all necessary SDK components from the server.

  • Forum posts: 4

Jun 2, 2016 2:21:46 PM via Website


I am not having a console to run the command under tools:


Maybe I should look into some other place to run the command?

  • Forum posts: 256

Jun 2, 2016 2:38:32 PM via Website

Open SDK manager, click "SDK Tools" tab and check components which was not installed. Search SDK manager in studio menu.

  • Forum posts: 4

Jun 2, 2016 6:00:08 PM via Website

There seems to be many which are not installed:


  • Forum posts: 256

Jun 2, 2016 6:15:07 PM via Website

If you don't need auto head emulator or Google Play Services you can skip them. Other components can be required for usual tasks.

— modified on Jun 2, 2016 6:15:52 PM

  • Forum posts: 207

Jun 16, 2016 3:08:21 PM via Website

close your android studion open command prompt

d: my system drive
Enviroment : location in side this is my sdk
sdk: my sdk location

replace with your's and try .