Huawei Ascend G525 — Huawei P9 Lite - Connect to PC

  • Replies:2
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Jul 9, 2016 10:44:03 AM via Website

Hi,

This is my first post. First of all, I'll like to say a big hello to all. I've decided to post in this thread under general issues.

I have a Huawei P9 Lite. Everytime I connect the phone to my PC, I have to manually go to the phone settings and select Media Transfer Protocol (MTP) under Select USB Configuration, then only I can transfer files to and from the phone and PC. How do I setup the phone so that I don't have to manually set these options every time I connect the phone to my PC? I want the phone to autoconnect to the PC every time I connect it to the PC. I didn't have this problem in my previous phone, Samsung Galaxy Mega 2.

Pls help thanks. Looking forward to reply.

From a frustrated Huawei P9 Lite user.

  • Forum posts: 251

Jul 9, 2016 8:56:48 PM via Website

Rainer Teh

Hi,

This is my first post. First of all, I'll like to say a big hello to all. I've decided to post in this thread under general issues.

I have a Huawei P9 Lite. Everytime I connect the phone to my PC, I have to manually go to the phone settings and select Media Transfer Protocol (MTP) under Select USB Configuration, then only I can transfer files to and from the phone and PC. How do I setup the phone so that I don't have to manually set these options every time I connect the phone to my PC? I want the phone to autoconnect to the PC every time I connect it to the PC. I didn't have this problem in my previous phone, Samsung Galaxy Mega 2.

Pls help thanks. Looking forward to reply.

From a frustrated Huawei P9 Lite user.

This started in Android 6.0 Marshmallow. Before that, there is no need to do that. Google (Android) makes it so troublesome for users.

This is supposed to be the solution, but may/may not work, because there are reports it didn't work on some phones even though the setting is Media Transfer Protocol (MTP).

Activate Developer Mode
- Goto Settings
- Tap About Device
- Tap Build Number 7 times to activate Developer mode

You will now have Developer Mode in Settings
- Goto Settings
- Tap Developer Mode (check under 'More' if you can't find it)
- Tap Select USB Configuration
- Select Media Transfer Protocol (MTP)

Generic instructions, not specific to Huawei phones

  • Forum posts: 2

Jul 10, 2016 6:09:43 AM via Website

pentel

Rainer Teh

Hi,

This is my first post. First of all, I'll like to say a big hello to all. I've decided to post in this thread under general issues.

I have a Huawei P9 Lite. Everytime I connect the phone to my PC, I have to manually go to the phone settings and select Media Transfer Protocol (MTP) under Select USB Configuration, then only I can transfer files to and from the phone and PC. How do I setup the phone so that I don't have to manually set these options every time I connect the phone to my PC? I want the phone to autoconnect to the PC every time I connect it to the PC. I didn't have this problem in my previous phone, Samsung Galaxy Mega 2.

Pls help thanks. Looking forward to reply.

From a frustrated Huawei P9 Lite user.

This started in Android 6.0 Marshmallow. Before that, there is no need to do that. Google (Android) makes it so troublesome for users.

This is supposed to be the solution, but may/may not work, because there are reports it didn't work on some phones even though the setting is Media Transfer Protocol (MTP).

Activate Developer Mode
- Goto Settings
- Tap About Device
- Tap Build Number 7 times to activate Developer mode

You will now have Developer Mode in Settings
- Goto Settings
- Tap Developer Mode (check under 'More' if you can't find it)
- Tap Select USB Configuration
- Select Media Transfer Protocol (MTP)

Generic instructions, not specific to Huawei phones

Hi pentel, thanks for your reply. I've followed your instructions. However, the problem still persists. Only one time it automatically displayed the Internal Storage screen successfully.

I think I have to go to Huawei Service Center to solve this problem.

Thanks for your help anyway.

Rainer