HELP!!! My 16gb internal phone storage segmented into 2 different parts

  • Replies:5
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Oct 9, 2016 1:26:00 PM via Website

I have mtk device (xolo-8x1000) with 16 GB internal storage
But now somehow it has been divided into 2 parts of 3.94 GB and 9.45 GB

Out of these 2 parts google play store an all other use the 3.94gb partition and the other one remains unused
image
image
image

I cannot find a way to merge those two partitions plz helppp!!

  • Forum posts: 4

Oct 9, 2016 7:28:51 PM via Website

Can you verify that it wasn't fragmented before? I suspect it was, and came that way.

What you are seeing is likely how the device was designed. Internal flash will be partitioned, and not all of it will be available to store apps. The rest will either be used by Android, or serve as an area to store data. I don't know of a way to merge partitions, and you would need to be rooted to even attempt it.

Xolo says the device has a microSD slot, which gives you a possible option if you can root the phone.

I had a problem with an older tablet that had a whopping 787MB of app storage, which was exhausted simply add standard Google apps. It had a microSD slot, so I got a 32GB microSD card. You can't store apps on a card as delivered. SD cards come formatted as FAT32, and you can only store apps on a Linux filesystem. I put the card into an adapter and repartitioned it from Windows, carving out a 2GB file system formatted as ext4, using a freeware program called Mini-Tool Partition Manager. I put the partitioned card in the tablet, powered off, and rebooted. Android saw a new filesystem on the card and mounted it.

Once it was in place, I could use a freeware app from the Play Store called Link2SD. Link2SD can take an app in internal storage and move it to the ext4 partition on the card, then place a symlink to it in the root file system. Android follows the symlink and runs the app. I was able to install what I wanted on the old tablet because I was no longer limited to internal storage.

See if there's a rooting program for the Xolo that will let you try what I did. If there isn't, I'm afraid you may stuck with the app storage you have and will just have to pick and choose what you really need to stay with device limits.

>Dennis

  • Forum posts: 2

Oct 10, 2016 8:44:14 AM via Website

Yes I am sure that it did not come that way
I have also tried the link2sd thing it didn't work

  • Forum posts: 4

Oct 10, 2016 9:05:05 AM via Website

I'll be very surprised if the 16GB internal storage was not partitioned. I think you just weren't aware of it. I can't think of anything you could do as an ordinary user that would partition it if it hadn't been.

Do you have a rooted device? Link2SD requires root to do what it does. If your device is not rooted, Link2SD can't work.

>Dennis

  • Forum posts: 73

Oct 10, 2016 12:31:51 PM via Website

Hi Dennis, this was a great solution for an internal phone storage.

  • Forum posts: 4

Oct 10, 2016 8:20:18 PM via Website

It's been useful for me.

There's an open source equivalent for Link2SD available in the F-Droid repo called Mounts2SD with a variety of features that is also worth a look. There's a discussion thread on XDA Developers about it

I discovered Link2SD first and it's what I use for the purpose, but it's not the only solution.

>Dennis