HTC One M9 stuck in bootloader with no other option

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 2

May 9, 2017 1:41:22 AM via Website

Hello,
I have a HTC ONE M9 from A1 Austria that I bought 18 months ago. It was working fine until 2 months ago after I charged it (I shut it down before charging). When I started the phone, it immediately showed the bootloader without any reason. The configuration of the bootloader is this:

* Software status: Modified
*
* Locked *
S-ON
*
Security Warning *

image

When it happened I selected boot to recovery mode and tried factory resetting it (I wiped cache partition too) but without success.... it still started in the bootloader. I let the phone rest.

I tried to fix it again today but unfortunately it got worse for some reason. Now I'm really stuck in the bootloader with no other option. Everytime I try to get in recovery mode or download mode it fails. Here are some pics illustrating my problem:image

image

adb commands doesn't work although HTC sync manager recognizes the phone. When I enter adb devices it shows me an empty list. Surprisingly fastboot commands work. I was able to get some information about my device but it seems like there is hardly any piece of software installed since I it has neither CID nor MID. Also it has no baseband and bootloader version. The only info that I can get is its Serial number. Here some pics:

image

image

The fun thing of the story is that I didn't even try to root the phone or unlock the bootloader. I bricked an HTC ONE mini in the past by trying to do so. I just put it to charge...

So that's it for now. Excuse me for this long text but I think the problem I have is rather uncommon so I had to describe it xD

So my question is: Could someone guide me (I am a noob at everything technical when it comes to android) step by step till I have a functioning phone back please?

Looking forward for all your answers :)

  • Forum posts: 2

May 18, 2017 7:58:55 PM via Website

Yeah its a shame. And no I dont have any backup data. But that doesn't matter. Only worthless files and apps. Any Idea how I could fix it or my problem is too unique and nobody knows and it is screwed?

Thx in advance :)