Phone numbers shown instead of names in WhatsApp

  • Replies:8
  • OpenNot stickiedUnanswered
  • Forum posts: 5

Dec 17, 2017 5:21:23 PM via Website

Hi from a newbie but not a green horn :-)

I have read many entries on the web about my problem but still don't have a solution that works. My Wiko PULP FAB 4G with Lollipop shows phone numbers instead of names. I have had this problem before, I followed all the advices found on the web but only one worked - namely, adding every chat to a existing contact (a window opens on top of every chat to do so). This time, this solution doesn't work anymore although that my phone says that it saved the contact that I indicated.

Could anyone please take me by the hand and guide me on the path to success? Thanks a bunch.

  • Forum posts: 5

Dec 18, 2017 6:18:11 PM via Website

Thanks for answering.

There are plenty of permissions given for this app by default - including the ones for "editing contacts" and "reading contacts".

  • Forum posts: 5

Dec 20, 2017 8:13:52 PM via Website

Do I still get a reply? It would make sending out seasons' greatings much easier. Thanks.

  • Forum posts: 538

Dec 21, 2017 2:42:16 AM via Website

lucky luke

Do I still get a reply? It would make sending out seasons' greatings much easier. Thanks.

You may need to reset the WhatsApp sync with your contacts. Here is how:

Open your phone's Settings app > Accounts > WhatsApp.
In the new screen, tap WhatsApp again > Menu Button > Remove account.
Open WhatsApp > Contacts > Menu Button > Refresh.

— modified on Dec 21, 2017 2:42:50 AM

  • Forum posts: 5

Dec 21, 2017 5:29:46 PM via Website

I did that. It didn't help, phone numbers instead of names are still shown.

I however noticed that there are many contacts missing in the Android contacts app - whereas in DejaOffice that I use for synching with Qutlook, all contacts are being shown. I had this difference actually before and it did not influence the behaviour of WhatsApp.

— modified on Dec 21, 2017 7:42:04 PM

  • Forum posts: 538

Dec 22, 2017 4:51:59 AM via Website

Settings - Apps - WhatsApp - Permissions - Set individual permission, enable 'Trust this app'.

If the steps above still cannot fix the issue you are experiencing, please contact your device manufacturer for more information regarding security permissions on your phone.

  • Forum posts: 5

Dec 29, 2017 8:20:52 PM via Website

I contacted the manufacturer of my device, but they did not answer.

However, I received a solution from companionlink.com, the authors of DejaOffice. They shall be praised! BINGO though :-)

  • Forum posts: 11

Dec 30, 2017 11:46:58 AM via Website

Same issue bugged me for days. I fixed it Going to the Security Application > Permission > Manage App Permissions > Apps tab > Select WhatsApp > turn on Trust this App. But glad you fixed it by following different instructions.