Android Auto on Samsung Galaxy S6 with Acura TLX

  • Replies:4
  • OpenNot stickiedAnswered
  • Forum posts: 3

Sep 30, 2018, 4:04:34 AM via Website

My android auto navigation works flawlessly on my Galaxy S6 smartphone as a standalone unit - GPS by/with voice, tracking, map display, etc. When I plug it into my 2019 Acura TLX, it connects right away and responds to voice commands to establish destination, route, but cannot lock on to GPS. It will follow the map with a faded indicator in some cases (while "searching for GPS"), but has no voice responses to route status. My dealer says the car just acts as a map display and plays phone audio through the car speaker phone but all GPS, tracking, etc is done by the phone. Clearly, that is not the case here - phone nav works, but no nav when connected to car. Any help out here??? It must be interface setup but I can't find the problem????

Reply
Best answer
  • Forum posts: 509

Sep 30, 2018, 12:10:04 PM via Website

On your phone, did you check your device pairing settings?
It might be turned off!

Helpful?
Reply
  • Forum posts: 3

Oct 1, 2018, 3:42:36 AM via Website

Lindsay, I thought my phone was properly paired. I had paired it with the car before I got the android auto app, and the phone worked great for phone functions. When I got android auto (AA), I plugged the phone into the USB connector and android auto gave me the message that it connected successfully. I was able to access AA through voice commands and initiate navigation. It would find my location and destination and map out the route. But from that point on, it would not navigate or give me any voice info, and constantly displayed "searching for GPS." I still thought the phone was properly connected because of all the other functions that worked. But your note led me to think maybe I should repair the phone now that I had AA installed, so I tried that. EVERYTHING works perfectly now... nav, phone, voice commands and feedback all! Thanks for your reply, and I posted this detail for others that may run into this problem.

Helpful?
Reply
  • Forum posts: 509

Oct 1, 2018, 11:49:07 AM via Website

You are very welcome!
Glad I could help!
Take care
Lindsay

Helpful?
Reply
  • Forum posts: 3

Oct 29, 2018, 3:37:49 AM via Website

I appreciate the help. However, I do have an update to my post. The phone Nav system using the TLX display is intermittent at best. Sometimes, but not too often, it works, but most times it is back to "searching for GPS" status. My son tried his Galaxy S8 and it works perfectly, EVERY time. It also comes up with an Android Auto settings menu when you first pair it with the car display, and I have never had that menu appear with the S6. You set it up once, and that's it with the S8. Apparently the S6 is not fully compatible, even though I a running Android version 7.0. Guess it's time for a phone update, and will use graphics off the phone in the meantime. BTY, the sound does play through the auto system via bluetooth while using it standalone for Android Auto navigation, but without pairing the phone via the USB port. That's a big help for me, and it's easy to turn on and off or change the volume with the car controls.

Helpful?
Reply

Recommended articles