Hotels show wrong currency in Android Google Maps

  • Replies:8
  • OpenNot stickiedUnanswered
  • Forum posts: 5

May 7, 2020, 9:22:22 PM via Website

My Android 10 phone shows hotels in the wrong currency in Google Maps - they are in EUR since I visited Europe a while back. I live in Canada. I was able to change back to CAD in the desktop version of maps, but not in Android. Here is what I have tried and this did not solve the issue:

  • clear the cache
  • force-stop the app, clear the cache, sign out of Maps, sign back in
  • factory reset the phone
  • buy a new phone.

Does anyone know how to solve this?

Reply
  • Forum posts: 5

May 8, 2020, 3:19:04 PM via Website

I have, indeed. And, BTW - I have the same problem with all phones/tablets that use this Google account, so it is not even Android-version-driven (I have Android 4, 5, 7, and 10 on 4 different devices).

Helpful?
Reply
  • Forum posts: 1,263

May 9, 2020, 3:00:01 AM via Website

Frauschlau

I have, indeed. And, BTW - I have the same problem with all phones/tablets that use this Google account, so it is not even Android-version-driven (I have Android 4, 5, 7, and 10 on 4 different devices).

I found a solution for the weird issue.
Go to Google Play Store, and search Google Maps, then unistall the app. At last, install the app again.
Have a try. It will work for you. (smug)

Download size < 0.07 MB. But also Accurate, Ad-Free & Full-Free.
The minimalist app available on Google Play https://goo.gl/ws42fN
Your 5-star is appreciated. Blog : https://okblackcafe.blogspot.com

Helpful?
Reply
  • Forum posts: 5

May 9, 2020, 3:49:46 AM via Website

Thanks for the suggestion. This does not work. The only uninstall option is to uninstall all updates and going back to the factory version. I did that, still back to PLN although I am in Canada and I already reset the preferences for the account, so the desktop version shows hotels in CAD. The android version - still in PLN. imageimage

Helpful?
Reply
  • Forum posts: 1,263

May 9, 2020, 5:10:17 AM via Website

Frauschlau

Thanks for the suggestion. This does not work. The only uninstall option is to uninstall all updates and going back to the factory version. I did that, still back to PLN although I am in Canada and I already reset the preferences for the account, so the desktop version shows hotels in CAD. The android version - still in PLN. ![image][1]![image][2]

[1]: https://fscl01.fonpit.de/userfiles/7689932/image/forum/Screenshot_20200508-214411.png
[2]: https://fscl01.fonpit.de/userfiles/7689932/image/forum/Screenshot_20200508-214510.png

Browse the default web page of Google, log on with your Google account.
Click on the More options button in the upper left corner. Scroll down to the Currency field and select CAD. Then go to your Google Maps app on the Android device, clear data & cache, open and log on with your Google id again.
Hope this will work.

Download size < 0.07 MB. But also Accurate, Ad-Free & Full-Free.
The minimalist app available on Google Play https://goo.gl/ws42fN
Your 5-star is appreciated. Blog : https://okblackcafe.blogspot.com

Helpful?
Reply
  • Forum posts: 5

May 9, 2020, 3:14:17 PM via Website

Thanks for following up.

Am I supposed to be doing this on the Android? I do not see a currency option in the Google account settings.

Changing the region in the desktop version did fix the issue for the desktop (I did that right after having returned from Europe), but not for the Android.image

Helpful?
Reply
  • Forum posts: 5

May 11, 2020, 3:33:48 PM via Website

James Watson

Frauschlau

Thanks for the suggestion. This does not work. The only uninstall option is to uninstall all updates and going back to the factory version. I did that, still back to PLN although I am in Canada and I already reset the preferences for the account, so the desktop version shows hotels in CAD. The android version - still in PLN. ![image][1]![image][2]

[1]: https://fscl01.fonpit.de/userfiles/7689932/image/forum/Screenshot_20200508-214411.png
[2]: https://fscl01.fonpit.de/userfiles/7689932/image/forum/Screenshot_20200508-214510.png

Browse the default web page of Google, log on with your Google account.
Click on the More options button in the upper left corner. Scroll down to the Currency field and select CAD. Then go to your Google Maps app on the Android device, clear data & cache, open and log on with your Google id again.
Hope this will work.

Actually, I tried a few more things and this is what worked on my Android 7 and 10 devices (but did not work on an older Nexus phone running Android 4):

1) Sign out of Google Maps
2) Force-stop the app
3) Clear cache
4) Clear data
5) Launch Maps again
6) sign in again if not signed in automatically when the app is relaunched.

Helpful?
Reply
  • Forum posts: 3

May 14, 2020, 10:21:25 AM via Website

Totally agee

Helpful?
Reply
Recommended articles