Bluxu SteepleChase Version 1.0

  • Replies:15
  • OpenNot stickiedUnanswered
  • Forum posts: 7

Dec 28, 2010 6:14:59 PM via Website

Hi everyone,

I've just published my first app to the Android Market and wondered what people think of it! The app is available free of charge, and there is a QR code and URL for market page at Let me know any suggestions for improvements by replying to this post, or leave me a review on the market! Many thanks!

Description: SteepleChase is a race against the clock which tests your navigation skills to the limit! In this fun and frantic game you must find your way around a randomised course armed with only the most basic tools. Compete with your friends to obtain the highest score on a course of any length you want - from a wander round your neighbourhood to a road trip across America!
  • Forum posts: 1,891

Dec 28, 2010 8:36:01 PM via Website

Here is a link to the AndroidPIT app database entry for the app. You can see all the same information about the app, but from your PC as well:

I'll give it a try later tonight and let you know what I think of it.

— modified on Dec 28, 2010 9:06:08 PM

  • Forum posts: 7

Dec 29, 2010 2:00:58 AM via Website

Thanks for your feedback Douglas - I'll look into that straight away. What phone were you using? Did it lock up on the license agreement or were the buttons just greyed out? I'll email you across a version of the apk without the license agreement as soon as I can so you can try it out. Thanks once again!
  • Forum posts: 1,891

Dec 29, 2010 11:10:18 AM via Website

I'm using a Nexus S with Android 2.3.

I loaded up the app, the user agreement page popped up, and then the screen immediately darkened a bit and the app just locked up. I downloaded it again to give it a second try, but no luck.

— modified on Dec 29, 2010 11:10:44 AM

  • Forum posts: 7

Dec 29, 2010 12:15:09 PM via Website

If you download the latest apk at that might fix the problem. If that still doesn't work then you could give me your email address and I can send you a version without the license agreement. Many thanks, and apologies for the bug!
  • Forum posts: 1,891

Dec 29, 2010 12:23:46 PM via Website

I downloaded the .apk from the website and it still had the same problem. I believe it may have something to do with Android Gingerbread.

No need to apologize. I like working with developers to help them fix any problems they have. I've PM'ed you my email which you can contact me at.
  • Forum posts: 7

Dec 30, 2010 10:03:07 PM via Website

Did you get the relevant apk I emailed across and try it out? If so did this solve the problem?

Many thanks!
  • Forum posts: 7

Dec 31, 2010 8:28:08 PM via Website

Thanks for trying that out. I'll have to have another go at trying to fix it. Do you have GPS enabled on your device before loading the game? If not could you try it with GPS enabled first and let me know what you see? Also do you see the Bluxu splash screen before the menu screen? If not that might be what's causing the problem! Seems like it is a Gingerbread issue since haven't heard bug reports from people on older versions of the sdk.

Thanks again for your help!
  • Forum posts: 7

Jan 1, 2011 5:48:21 PM via Website

Thanks very much for trying that - I think I've pinned down the problem now. If GPS isn't switched on SteepleChase should prompt you to turn it on, but it seems that displaying this dialog in Gingerbread crashes the app. I'll come up with a fix asap.

Do let me know what you think of the app itself. If anyone else has any feedback I'd be delighted to hear it!


  • Forum posts: 1,891

Jan 3, 2011 12:26:45 PM via Website

The app never managed to get a fix on my device, indoors or outdoors. I had half the sky visible to my device when I tried it outdoors. The GPS does work on the device, as I used it quite frequently yesterday. It quit trying to search before it managed to get a fix. Is this meant to be an outside app only? Do you have access to the way that Google determines rough location using Wi-Fi networks?

— modified on Jan 3, 2011 12:27:22 PM

  • Forum posts: 7

Jan 3, 2011 5:48:04 PM via Website

Weird that the GPS doesn't seem to work for you. It works fine both inside and outside where I live. How long did you leave the app running before giving up? As soon as it starts running the app looks for GPS and after the Solo screen it gives itself another 10 seconds to look before giving up. I find that sometimes I have to try this twice especially if I am indoors since it takes a while for the GPS to lock on. Do you think functionality would be improved if the app just waited until it got GPS signal rather than giving up after 10 seconds? I'll try and see whether this is a Gingerbread issue too in the next couple of days.

With regards to the rough location stuff I could implement that, but it wouldn't really give me precise enough data to run the app. I'll look into putting it in as a backup on later releases though!

Thanks one again for your feedback and perseverance!