Samsung Galaxy S2 — Wifi enabling problem with ICS SGS2

  • Replies:6
  • OpenNot stickiedUnanswered
  • Forum posts: 5

Apr 16, 2013 6:37:24 PM via Website

I'm having this problem of enabling my wifi with my galaxy s2 phone. Whenever I turn it on for the first time after a reboot, it turns on. Then I switch off the wifi because I'm about to travel so there's no use having it on. When I get to the office then switch on the wifi, it doesn't turn on, then ends up resetting itself then when it comes back on, the wifi is switched on. I'm not sure what's happening with my phone, but this is giving me trouble whenever I'm doing something with my phone then I need a wifi connection. I want it to be back to how it was when I can switch it on and off without having to reset it. Any suggestions on how to fix this issue? My S2 is still currently using ICS and I'm not yet updating it. will the jellybean update fix this problem?
  • Forum posts: 1

Jun 13, 2013 11:46:58 PM via Website

I'm having the same problem on my ICS S2. Intermittent problem that Wifi doesn't want to turn on at this mes. The Wifi icon just turns to a dull green, not all the way to the bright green it's supposed to be when it is on. Wifi freezes at that point (still offf). As you can see it also EATS my battery (see far right). Have you found a solution?

I can't upgrade to jelly bean in my country.

  • Forum posts: 1

Aug 20, 2013 5:47:08 PM via Website

I'm having this problem too, I have to restart my phone sometimes to get it to connect the wifi and even when I do that (rather than waiting for my phone to eventually crash) it eats up loads of battery. If I just leave it eventually the phone just crashes and I can't even get it to come back on without removing and re-inserting the battery. I'm on android version 4.0.3.
Loie Favre
  • Admin
  • Staff
  • Forum posts: 1,116

Aug 21, 2013 11:31:57 AM via Website

I've found several possible solutions:

Possible solution #1 Try this:
Go to Settings -> Wifi -> click on menu button on bottom of device --> select advanced --> open frequency band --> click off Auto, on 2.4 GHz only.

Possible Solution # 2: You can also try this:
Switch on Wi-Fi --> switch on Airplane mode --> turn Airplane mode off --> WiFi should be restored.

The normal way of setting up WiFi is done so:
Applications --Settings -- Wireless and Networks -- WiFi settings -- press to turn on WiFi -- select WiFi network --press connect --it should automatically connect and you should only have to do it once. but if this isnt working, try the two solutions above.

Did any of these solutions work? If not, we will keep looking.
  • Forum posts: 9

Aug 26, 2013 5:24:44 PM via Website

i don't have any problem, works perfectly.
  • Forum posts: 1

Mar 5, 2015 5:39:02 AM via Website

Hi loie
I tried it but no result. Still facing while enabling wifi and ultimately need to re start :'(