Samsung Galaxy S3 mini — Cannot connect to wifi

  • Replies:3
  • OpenNot stickiedUnanswered

May 16, 2014 10:49:32 AM via Website

Hi there,

I am having a problem with my Samsung galaxy S3 mini. I have a wifi router at home, and simply cannot connect to it on my Samsung, unless another device in the house is already connected to it. I.e. if I log in to the wifi on the computer first, then my phone will connect. Else it won't. Its strange because my phone will say it has connected, and it looks like it has. But the browser will not work and none of the apps will either.

I have tried forgetting the network and starting over, but it did not help. If anyone has any ideas, please let me know!

Thank you.

Loie Favre
  • Admin
  • Staff

May 16, 2014 11:15:55 AM via Website

Hi Jacqueline!

Your problem sounds quite annoying.

Here are the solutions I suggest for this:

Solution 1
Delete this WiFi configuration from your phone.(You don't need#0011##. Just tap on that WiFi connection in Settings.) Reboot the router. Double check the router setup to see what type of security is enabled. For the initial setup, at least, make sure the SSID is visible. Recreate the connection on your phone.

Solution 2
Press these menu options on your phone: Settings > Wi-fi> (Choose your network by tapping on it for a few seconds) > Modify network config
Check "Show advanced options"
Choose IP Settings: "Static"
Enter these details
IP - or
Gateway - (I chose since that's my router address)
NPL - 24
Netmask - (I could not find this option)
DNS 1 - or (I had the latter by default and let it stay)
DNS 2 -
And save. It should connect.

Solution 3
A third solution that might help in addition to doing the above includes turning off a couple of Wi-Fi settings. Go into the Advanced menu from the Wi-Fi settings on the S III and uncheck Network notification and Auto connect.

Solution 4
Open the Phone app and dial *#0011#. This opens a special “ServiceMode”. From here, tap the menu button and go into WiFi and then hit the ON button to switch it to OFF. Hit the back button twice to exit the screen.

I hope one of these solutions works! If not, let me know and I'll keep on looking for a plausible solution :)

Mar 21, 2015 3:36:22 AM via Website

I have been using my phone in Nepal for one year. Just last week it would not connect to the wifi in my home, but will connect in other people's homes and at work. I tried solution 2 but when I changed to "static" i couldnt select "connect". tried solution 1&3 - wouldnt work.