Samsung Galaxy S2 — Wi Fi not getting OFF

  • Replies:6
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Jul 20, 2014 3:11:20 PM via Website

I am having Samsung Galaxy S2 (GT-I9100). Wi -fi is not getting off. continuously scanning. Battery discharging very fast. pl suggest how to fix problem.

  • Forum posts: 598

Jul 22, 2014 10:22:32 AM via Website

My device has the same problem with battery. I have to charge it 3-4 times per day.

Regarding the Wi-Fi thing... do you have any battery defender apps installed? Like juice defender or something?

Sometimes those kind of apps will automatically turn the Wi-Fi on or off depending on your battery's state.

Check if you are running any apps that would make changes to help battery/performance.

Lalit
  • Admin
  • Forum posts: 2,151

Jul 23, 2014 7:58:47 AM via Website

Well, Firstly like @Scott said try searching your application i am having a doubt that this might be happening because of some application installed over your device, if you can't find any I would suggest try switching your device to off for sometime and then again restart the device and see if the Wi-Fi still turns itself back on ! :? 

— modified on Jul 23, 2014 7:59:04 AM

  • Forum posts: 2

Jul 23, 2014 5:31:40 PM via Website

I had downloaded Battery defender but it did not work.

  • Forum posts: 54

Jul 24, 2014 11:40:36 PM via Website

I had Galaxy S Duos long back and there it was having the same problem, wifi wasn't turning off. I did every possible move from side like restarting, factory resetting and flashing too but all in vain. I took it to the service center and it had a mother board issue. I had to completely change the board. I hope you are experiencing the same problem.

  • Forum posts: 678

Jul 25, 2014 4:45:35 AM via Website

CV Ravindra Nath

I am having Samsung Galaxy S2 (GT-I9100). Wi -fi is not getting off. continuously scanning. Battery discharging very fast. pl suggest how to fix problem.

First go to safe mode and see whether the problem exist

if the problem exist it will be a software bug

Reflash your firmware with odin after that clear cache and factory reset form recovery.

All your data will be lost . you can make a backup with HELIUM apk from play store

— modified on Jul 25, 2014 4:49:55 AM

Ready To Help You.

  • Forum posts: 1

Dec 27, 2014 12:32:16 PM via App

I heard that providers asked for this setting to automatically be on to save there own bandwidth! It really eats the battery. To change this setting: Go to Settings, more settings, mobile networks, connection optimizer (Intelligent mobile network & wifi settings), and deselect the option. If you look at this option again, DO NOT accept. That will turn it back on!