Transfer files Xperia Play

  • Replies:5
  • OpenNot stickiedUnanswered
  • Forum posts: 5

Aug 21, 2011 5:46:22 PM via Website

Hi, I just got a new Xperia play but I'm having trouble transferring big files to it. I keep trying over Bluetooth but it takes forever. What's the best way to load big files, quickly onto the phone?
  • Forum posts: 882

Aug 22, 2011 10:24:13 AM via Website

The fastest way is definitely by using the included USB cord. Connect the phone to your computer, and the message "Phone: Connected in Media transfer mode" should appear in the status bar. PC Companion should automatically start on your computer. Click on it to start File Manager then simply drag and drop desired files between your phone and the computer.
  • Forum posts: 5

Aug 22, 2011 5:11:10 PM via Website

Thanks for the info! I've tried the USB method and I see the Media transer mode message but I can't see the drive on my computer. The phone keeps trying to install software but can't because I have a mac. Do you think that has something to do with me not being able to transfer files?
  • Forum posts: 842

Aug 23, 2011 1:02:00 PM via Website

That could be an issue. One problem I was having with my Xperia was that I was trying to send files over bluetooth and it was taking forever. The problem was that the files were on an external HD which bottlenecked the transfer speed and caused the dely. You might be having a simiar issue. Makre sure all the files are on your main HD or one with a fast transfer rate. That might help.
  • Forum posts: 1

Sep 17, 2011 9:59:59 AM via Website


Try selecting mass storage mode. This allowed my Xperia Mini Pro to be mounted on the file system on my Mac running Snow Leopard. Make sure your finder settings show remote hard disks ++.

Good luck.
  • Forum posts: 842

Sep 19, 2011 11:17:27 AM via Website

@Simon Really? And you could view it like a normal drive through the finder window and transfer files via the USB cable? Because Ive been trying to figure that out for three weeks and have been having a devil of a time. I run a macbook with Snow Lep. and a pro with Lion and I couldnt get it to work with either... Im going to try this out later. Thanks for the tip.