Mono for Android 4.0.1 Simplest App Won't Run on LG GT540 android ver.2.3.7

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jun 22, 2012 5:44:44 PM via Website

here's the problem :
xp sp3
vs 2010 ultimate
monoandroid 4.0.1
- android 4.0.3 (API 15)
- android 4.0 (API 14)
- android 2.2 (API 8)
LGDrivers (I think, that is not necessary)
after i create the default app (with Button and click) in VS 2010
1. run with no debugger
( I try with both API 14 and API 8 too )
And I get :
2. adb install -r
i receive a text saying "success" and it works on my emulator
amazing wonderful BUT :

when I run this on my LG GT540 currently running android 2.3.7 version I get a message saying:
sorry, application has unexpectedly stopped ..
What Android OS mean ?
I also tried
1 copying the -Signed .apk to the phones manualy and install with phone Android installer it still didnt work
2 I also rebooted the phone after instaling the app. it still didnt work
So, successful at my emulator with VS 2010
succesfull with command adb
BUT wrong when I start at my phone ( the same message in all cases .. application has unexpectedly stopped )
what am i doing wrong ?
I wont give up from mono for android. Its wonderful and new for me like C# programmer.
I only wont to see default mono app running on my mobile device.