ICS firmware upgrade faliure

  • Replies:6
  • OpenNot stickiedAnswered
  • Forum posts: 2

Jul 10, 2012 5:39:56 PM via Website

Let me start by saying;
Hey Everyone! I'm new to the forums so greetings to everyone and thanks for having me!

My phone is rooted. i rooted it installed the app and then flashed the original kernel back to the phone.
I just ''tried'' to install ICS onto my S2 but it failed.
I plugged my phone and in kies prompted me to update the firmware as i expected, so i agreed and clicked continue.
It proceeded to do its thing and downloaded fine and started to install to me phone. the insulation screen had finished and i got a message telling me
"insulation failed try emergency recovery" so i wrote down the code and clicked continue. It also failed telling me to unplug my phone, take out the battery, turn it on and plug it back in. now when i turned the phone on i got a -yellow triangle- in between a phone and computer. so i pluged in into the pc and emergency recovery popped up and prompted me to plug my phone into a usb 2.0 port. so i unplugged it changed the port and again prompted to run emergency recovery so i ran it and it failed again.

So now the phone is stuck on this screen with the triangle and phone/computer doing nothing.

*i can get the phone into download mode*

  • -I was thinking to flash the original ROM back onto the phone but now i cant turn it on to get the kernel number and the other details i need. i foolishly deleted the folder with all the files i used to flash my phone a few days ago (oh the beauty of hind sight)
  • -I've tried hard reset (as a last resort) but i can get into that option (holding up volume. home and power for a few seconds)
  • -Is it possible for me to install a custom ROM onto my phone with out the rooted kernel installed? (but the phone has the rooted app )
    If i could install a custom ROM so i can remove my Data from the phone and then reset it to the original settings
    *or if need be ill keep the custom ROM*

Any advice would be great.

Thanks for reading
Many thanks
  • Forum posts: 1,811

Jul 11, 2012 4:11:09 PM via Website

Hi Jake, and welcome!

If I were you, I wouldn't use Kies to flash ICS. Since your already rooted, you don't need a PC to flash ROMS. Just do it in recovery!

Can you still access recovery on your device? If not, we can still use Odin to flash a custom ICS ROM for you (I recommend CyanogenMod9).

Also, here's a video where I walk you through installing custom ROM on the Galaxy S2 with recovery:


Instead of download the ROM I put in that article, download the newest Ice Cream Sandwich ROM from here:


Let me know how it goes!
  • Forum posts: 2

Aug 14, 2012 6:51:00 PM via Website

hey thanks for the reply,
i have another problem.
Seem to have nothing but problems with this phone haha.

Oh and i managed the fix the ICS problem. I think i just got lucky and it installed via Kies.

But now im having another problem with the same phone.

Heres my post from another forum. ill cut all the crap out.

Hey everyone,

When i first got my phone i rooted it after a few weeks of having it, in a attempt to unlock my phone using a free app as i was going abroad.
It wasn't successful.

A few months later coming back from my trip abroad i updated my phone to 4.0.3.

Now going abroad again i needed to get my phone unlocked and visited a shop today that was recommended to me by a friend.

after having some trouble updating my phone to ICS 4.0.3 i got paranoid and noted down all the information for that phone, Just in case i needed them.

so in the shop the guy takes my phone and goes into the back room and tells me it will take 10mins.
He comes back 5mins later and tells me he needs to roll back the firmware to 2.3.6 but reassures me that he will upgrade it to 4.0.3 once it is unlocked,
Ok i agree and let him do what he needs to do.

30 mins later he comes out and tells me my phone doesnt have enough battery to upgrade it to 4.0.3 but claims that it is now unlocked.
Luckily my father was on hand with his Galaxy S2 and offers me his battery. (now 40mins into the process i wasn't about to walk away with a half assed job)
So we waited and a hour later he walks about and tells me that my phone wont accept the update for 4.0.3 and that he is downloading the firmware to flash it to 4.0.3.
He told me to come back after lunch and he will upgrade it if i want him too.

I told him it was ok and i was happy with 2.3.6 as long as my phone works.

Now home and tested my new unlocked phone with various sim cards i was happy with the result.
Untill a few moment ago i attempt to connect it to my pc to transfer the data i lost during the flashing and unlocking process.
my pc wont recognize the device.

Here are my before and after notes that i took down.

Model Number: GT-I9100
Android Version: 4.0.3
Basband Version: I9100BGLP2
Kernel Version: 3.0.15-I9100BGLP8-CL317471 dpi@dell151#3
Build Number: IML74K.BGLP8
Phone: I9100BGLP2
CSC: 19100XECLP5
H/W Version: Rev1.5

Model Number: GT-I9100
Android Version: 2.3.6
Baseband Version: I9100BVKL1
Kernel Version:
Phone: I9100BVKL1
H/W Version: Rev1.4

The firmware installed is nothing like my previous version of GB as it is now the Orange (the service provider) version of the firmware.

The only real problem i am having is with connecting it to my computer.

I was also wondering if anyone could offer me up a solution for getting it flashed back to my old firmware...
Now that the phone is unlocked can i flash it to whatever my hearts content ?
Does anybody know how the unlocking processes works?

Thanks for your time reading.
  • Forum posts: 196

Nov 6, 2012 10:37:17 AM via Website

Hi Jake and Eric, the best way to install a firmware on an S2, original or otherwise,is using Odin. much faster.

You will find all you ever need to know here ;-)


PS. put the 4.04 original Samsung firmware on it :


good luck

drop me a note if you need help

— modified on Nov 6, 2012 10:43:02 AM

  • Forum posts: 6

May 16, 2013 12:33:31 AM via App

md jahed
phone power of hoi na