How to Install Flash Player on Android

  • Replies:36
  • OpenNot stickiedUnanswered
  • Forum posts: 3

Aug 21, 2013 12:28:57 AM via Website

OK I went to tool>add-on but there is no plugins after that. I went to settings>plugins and they were disabled so I enabled them. I went back to tools>adons and the flash is not there. I located it in the same place as all the other apps. Do I need to change the location and if so How do I do that. I have never used an android device for much more then checking email and such so this is pretty unfamiliar to me. So please remember that you instructions would need to be pretty specific.
You said to go to tools>addons>plug-ins but I could only go tools>addons and then it showed a list of addons but no flash player.
  • Forum posts: 3

Aug 21, 2013 12:35:48 AM via Website

I might add that I loaded the file on my external micro SD card and installed from there. Could this be the problem. Like I said the flash file shows up when I go to settings>apps and when I go to my application manager it says the app is running.

— modified on Aug 21, 2013 12:37:50 AM

  • Forum posts: 1,338

Aug 21, 2013 11:00:18 AM via Website

Hey Tom, my bad, I just gave you the path for PC off the top of my head, not Android! Sorry for the confusion, but you figured it out fine on your own. If you go to Settings > Plugins and Enable them, that should be all you have to do (you can of course, leave it as ''tap to use'' which means you'll see the little grey box wherever Flash content appears and you just tap the box to launch the Flash plugin, but this is pretty clumsy). Even after the plugin is installed it won't appear in the Add-ons tab (shown below for other readers' reference):

After I did that Flash started working. Not immediately mind you. I first opened Firefox and had the same problem as you did, then I opened the Flash Player Settings app that you may not have seen was installed when you downloaded the plugin in another browser (because it would not display in Firefox yet). I set my preferences there and when I exited and relaunched Firefox it was working.

Try this (not very technical, I know!) process and see if it works for you too. It may just have been a simple matter of waiting a short while after install for it to take hold as I can't really see how setting preferences would make a difference! You can go to this test site to see Flash content and ensure it's working:

— modified on Aug 21, 2013 11:04:11 AM

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

  • Forum posts: 1

Sep 7, 2013 6:29:54 AM via Website

Hi, Kris. My problem seems most similar to Tom's.

I'm using an ASUS Transformer Pad TF300T with Android ver. 4.2.1 and the Firefox 2.2 browser.

I somehow missed your latest answer to Tom, so I've withdrawn earlier questions.

After trying your latest suggestions, it works! Sort of. Well, in some places: on the Player Test Site and a few others, but all I get on a number of others is an error message about the file being corrupted or, if I open Flash directly, I see: "A plugin is needed to display this content."


— modified on Sep 7, 2013 7:04:29 AM

  • Forum posts: 2

Sep 18, 2013 6:34:42 AM via Website

I followed your directions for my new Tab 3 (SM-T310) which is using 4.2.2 I could not get the Flash Player to work using Firefox :(
What can I try?
IT work great (in the morning when I re-powered it)
Tested on several Flash Player sites and then when I gave it back to my 12 year old grandson, he was able to log on the the Palm Breach County School District Web Site (every thing is Flash Player) it work better that the families lap top.
Deactivated Account
  • Forum posts: 72

Nov 12, 2013 11:15:23 AM via Website

I've always missed flash !! well now its available for Android !! luv it thanks for sharing admin :wub::wub:
  • Forum posts: 1

Dec 6, 2013 12:16:42 AM via Website

Hey Kris, I am having nothing but problems here, I have downloaded the latest version of flash (.81) I have tried the dolphin browser with the jetpack extension installed on my device also firefox and firefox beta, nothing seems to get flash running on any test page I go to, in any browsers at all.
I just cant seem to get any luck... you did say you could open the settings in 'another browser' i can see yhe icon and that it has installed but which browser did you use as with all the browsers on my tablet I get the same grey screen with no info apart from firefox beta, which shows a jigsaw/lego like piece saying 'an addon is needed to run this' and when I click, no further options or anything appear.... I have checked other forums and it seems to be an ongoing problem with the 10.1 samsung tab 3 so do you think its this tablet or am I missing something?!?

Cheers in advance for any help!

Forgot to mention I have also tried the previous 2 editions from the adobe site and left it over night and also powered off and reset the tab and still no avail :/

— modified on Dec 6, 2013 12:18:46 AM

  • Forum posts: 1

Jan 9, 2014 7:31:53 AM via Website

I hope somebody still reads this. I am doing everything according to the instructions, yet when I am trying to access any kind of web page with Flash on it, it just says that I need a plugin, though I cant tap on it or anything in order to install one.

Galaxy tab 3 10.1
  • Forum posts: 16

Jan 24, 2014 7:06:01 PM via Website

THANKS!!!! :):):)
  • Forum posts: 1,338

Jan 26, 2014 1:12:47 PM via Website

Hi @Andrejs, yep, still reading. If you can fill me in on the specifics of the problem I might be able to help. ie, which browser, which archive version and the process you use (and where the problem occurs).

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

  • Forum posts: 1

Mar 10, 2014 12:04:36 PM via Website

HI! I followed your instructions and it worked well for 3 days. I tried to reinstall it but android seems to be blocking it, Any ideas?
  • Forum posts: 1,338

Mar 10, 2014 6:14:16 PM via Website

Hey @Venite, what browser are you using? And did it work perfectly for three days and then just stop? Did you do anything on that third day that you think might be responsible? How do you know Android is blocking it?

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

  • Forum posts: 10

Mar 24, 2014 9:04:00 PM via Website

Super helpful!!! I did this with my Samsung S3 and it worked great! Thanx!!
  • Forum posts: 26

Jun 2, 2014 12:42:05 AM via Website

Hi Kris I don't know if this site is still Up - to date , I mean the problematic with the latest version 4.4 kitkat. I have installed the modified version of the Adobe Flash player after fallowing the description. I have tried from both sides 1 . the xda's way and 2nd the directly installing from dolphin browser. And I have uninstalled and reinstalled again, but when I want to look "Deutschland TV"(an app developed by "flash paradise";) i can't open it .It says:"get adobe flash player".Is this maybe a "sync"-problem , a" connection problem "between dolphin browser and the TV - APP? Both the icon and the file of Adobe Flash player are transparent on my Galaxy s4 device.
The greatest thanks to you if you can help me
..I thank you anyway when you tried to help me

  • Forum posts: 1,338

Jun 10, 2014 10:49:11 AM via Website

Flash Player won't work on all KitKat browsers. Dolphin should be a safe bet though, so I'm not sure why you're getting an error. Have you treid uninstalling/reinstalling? (not very technical I know, but it sometimes works). I'm sure you've followed the XDA directions well, but perhaps double check in case you missed something?

The only other thing I can think of is that you have a previous version of Flash Player already installed on your device. Make sure you've deleted that before getting the latest version.

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

  • Forum posts: 3

Mar 6, 2015 3:23:37 PM via Website

I did a direct download via chrome some time back, i'am on 4.3 and have had a 4.4 update waiting to be downloaded for sometime now but haven't
done so because of moving files to the sd card in that version but have found workarounds so was thinking of updating. You mentioned something
new to me that flash doesn't work in 4.4, does this also apply to 5.0 and if so is their any sort of workaround for this? I also use photon browser which you may probably know is flash enabled but wouldn't imagine this will cover all flash enabled needs? I would appreciate your input on this, thanks.