Google Nexus 6 — No messages in All Mail Folder

  • Replies:2
  • OpenNot stickiedUnanswered
  • Forum posts: 4

May 18, 2016 4:20:56 PM via Website

Nexus 6,
Build: MOB30l

In g Mail - the All Mail folder shows no messages.

Other folders show messages.

There were over 5000 messages in All Mail folder.

Any solutions?


  • Forum posts: 15

May 19, 2016 7:44:41 PM via Website

I had the same problem with my Samsung Galaxy S5 & S6. It's in the SYNC settings within Gmail.

Go to Gmail app and go to "Settings".
Select your email address, below "General Settings".
Scroll down to "Data Usage" section.
Make sure "Sync Gmail" is checked.
Select "Days of Mail to sync" and change to "30 days"
Select "Manage Labels"
Select "All Mail" and then select "Sync Messages"
Change to "Sync: None" (I know this sounds weird but it works).
If you have a lot of folders, like myself, there are only certain folders that should be synced:
- Inbox - Sync: Last 30 days
- Priority Inbox - Sync: Last 30 days
- Sent - Sent: Sync All
Then close out the app, and reopen. This has worked for me and several people I know that are on different devices. Good Luck!!!!

  • Forum posts: 4

May 20, 2016 2:59:25 AM via Website

Thanks - I had eventually figured it out. More so, since on my MacBook the folder was appearing fine.

Weird way, but true and it worked.