can't get android studio to run app in emulator

  • Replies:6
  • OpenNot stickiedUnanswered
  • Forum posts: 9

Jan 6, 2017 12:25:39 AM via Website

I am learning Android App development and cannot get anything to run in the emulator.

I created a simple "Hello World" app and am getting these errors"

Intel HAXM is required to run this AVD
Your CPU does not support VT-x
Error while waiting for device: Could not start AVD

My development PC is Windows 10

  • Forum posts: 266

Jan 6, 2017 5:43:45 AM via Website

You need to change the platform type of emulator from x86 to arm-eabi.

  • Forum posts: 9

Jan 6, 2017 5:21:56 PM via Website

It will not allow me to select an arm emulator. If I go into
tools/
I can download any version of android but it will only allow me to select Android 7 Nougat. If I select any other the OK button is grayed out.

If I select that I get this error:
Your CPU does not support VT-x
Consider using an x86 system image on a x86 host for better emulation performance

If I run the app using this emulator, it crashes with this error
qemu-system-aarch64.exe has stopped working

  • Forum posts: 266

Jan 6, 2017 8:34:18 PM via Website

image

Click "Show package details" checkbox

image

Is "ARM EABI v7a System Image" checked?

image

For other android versions download respective ARM EABI System Image.

— modified on Jan 6, 2017 8:38:14 PM

  • Forum posts: 9

Jan 6, 2017 9:11:21 PM via Website

You are right I did not have ARM EABI selected.

When I chose an Android version with ARM the emulator opens. But after a while I get this error
Error while waiting for device: Timed out after 300seconds waiting for emulator to come online.

  • Forum posts: 266

Jan 6, 2017 10:36:48 PM via Website

Try to use lower settings for emulator:
RAM 256 - 512 mb, 800×480 resolution, no sd card, internal storage 100 mb.

  • Forum posts: 9

Jan 6, 2017 11:47:15 PM via Website

I could not use those exact settings, but I did set the resolution to what you recommended.
It would not allow me to save the AVD unless
SD card must be larger than 10mb
Internal Storage must be at least 200mb

I did run the app with the settings
800×480 resolution
RAM 256mb
SD card 11mb
Internal Storage 200mb

After about 10min I now get this error
Process pipe failed
I/OpenGLRenderer: Initialized EGL, version 1.4
E/EGL_emulation: tid 2568: eglSurfaceAttrib(1165): error 0x3009 (EGL_BAD_MATCH)
W/OpenGLRenderer: Failed to set EGL_SWAP_BEHAVIOR on surface 0xac1ed5c0, error=EGL_BAD_MATCH
W/art: Verification of boolean android.support.v7.widget.ActionMenuPresenter.showOverflowMenu() took 111.462ms
I/Choreographer: Skipped 96 frames! The application may be doing too much work on its main thread.