Alarm in statusbar reappears while off

  • Replies:3
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Nov 5, 2018, 10:33:18 AM via Website

Hi!

I'm experiencing some kind of bug I think.

So even though I have no alarms set, my status bar shows the alarm icon. But here is the catch: when I open the stock alarm app, the icon disappears, as if my phone realises it should not show the alarm icon. After some time (minutes) out of the alarm app, the alarm icon wil reappear.

I have forced the alarm app to stop, as well as restarted my phone. Many posts seem to suggest that the problem is that there is another app with an alarm, but in my case there isn't, and that doesn't really make sense in my situation anyways, right?

Any suggestions on what I should do? Many thanks in advance!

Edit: Found the solution. Use system UI tuner to disable the alarm icon. You have to enable system UI tuner first though, which isn't that easy on EMUI. But Google will help you with that ;-)

— modified on Nov 13, 2018, 6:45:49 PM

Reply
  • Forum posts: 417

Nov 5, 2018, 11:49:06 AM via Website

Two suggestions;
Turn off notifications for your alarm app.
Or clear all the data on the alarm app.
Then restart your phone.
You can do both in setting on the all apps
Selection!

— modified on Nov 5, 2018, 11:50:50 AM

Helpful?
Reply
  • Forum posts: 13

Nov 5, 2018, 8:13:56 PM via Website

I had the same problem but it disappeared somehow without my help

Helpful?
Reply
  • Forum posts: 2

Nov 13, 2018, 6:44:38 PM via Website

Thank you for your answer, but sadly enough those suggestions didn't work for me.

In the mean time, I googled ways to deinstal the app but I didn't find any that works. It seems I would have to root my phone, but I don't feel confident doing that.

I also had this idea to use an app blocker, but that doesn't help either.

Then, I downloaded a app to customize my status bar, which let me disable the alarm icon. I did have to give a lot of permissions thought, something I never like to do. But the app was buggy, sometimes my old statusbar would show up again.

Thankfully that app ended up showing me the solution. You have to enable system UI tuner (which isn't that easy on EMUI, I had to download an app to do that, you can google how to do it). There, I could to disable the alarm icon.

I edited the openingspost to include the solution that worked for me.

Helpful?
Reply

Recommended articles