Help! Trying to root ZTE Majesty

  • Replies:7
  • OpenNot stickiedUnanswered
  • Forum posts: 3

Oct 13, 2013 11:20:46 PM via Website

Hey guys, new here! I just bought a new ZTE Majesty from Straight Talk. It arrived just today and ever since I got it, I've been trying to find ways to root it... but to no avail. I've tried several different methods such as doing it manually, Superoneclick, and this one way I found on Youtube (I think it's called zRoot... search: How to Root Android 4.1.2 (Jelly Bean)(Universal Method)). Now, the one on Youtube actually kind of WORKS, but the problem is that it doesn't stay... and when you try to run a root program, it says something like "Superuser cannot request super authority" or something like that. After a restart, the Superuser disappears from the phone.

I do realize this is a new phone and all... and what makes it worse is that it is Android 4.1.2. There has got to be someone out there who has cracked this already. If there is, please do help. My brain is melting from trying to figure this stuff out XD

Thanks so much you guys.

Also... I have tried Motochopper and Kingo, but no success.... even though they said they were. But I don't see a superuser and using root checker, it says I don't have root.

— modified on Oct 13, 2013 11:22:33 PM

  • Forum posts: 3

Oct 17, 2013 9:46:08 AM via Website


Has anyone found any answers to rooting this phone? I've tried everything out there... hmm... I guess I'll have to wait a bit longer I suppose.
  • Forum posts: 164

Oct 23, 2013 8:00:10 PM via Website

Straight Talk phones are extremely hard to root. I had to fight to get my Samsung Galaxy Centura rooted, and that's a Samsung (i.e. common and popular) phone. Granted, I got it rooted, but you might just want to get a better phone. I did, at least ... the thing is, even my go-to Straight Talk root forum (Android Area 51) doesn't have any ZTE Majesty tips. Unpopular phones are far less likely to have devs. Sorry 'bout that.


--I do a good impression of myself--

Deactivated Account
  • Forum posts: 72

Nov 6, 2013 12:13:52 PM via Website

Best way is to use One click rooting !! :bashful::bashful:
  • Forum posts: 3

Nov 9, 2013 3:27:02 AM via Website

I've tried One Click but it didn't work =/ It said that my device isn't guaranteed and it failed.
Deactivated Account
  • Forum posts: 72

Nov 11, 2013 1:20:12 PM via Website

oops !! wait for some time i'll see what i can do .
  • Forum posts: 1

Feb 13, 2014 6:01:59 PM via Website

Im having the same problem cant root this phone been trying all day I've tried everything i can think of and looked up every video also no luck it a pretty good phone i just want full access and get rid of the bloat-ware ANY SUGGESTIONS..WOULD BE APPRECIATED ......THANKS...