Samsung Galaxy S4 — Since upgrading to Kitkat My S4 keeps dropping my carrier

  • Replies:20
  • OpenNot stickiedUnanswered
  • Forum posts: 6

Mar 22, 2014 1:51:09 AM via Website

Ever since the upgrade my phone keeps randomly dropping my carrier and showing no signal. Never had this situation since upgrading. I've missed several calls and many txt's. Tried the hard reset (removed Bat) but have not done the factory reset for fear of losing data. So far it seems unique to me as no one else seems to be reporting on this prob. If there is no solution I may have a paperweight. it was rocksolid prior to the upgrade. Also, the signal was dropped while phone was stationary and showing 3 bars. I actually saw it go once while flipping between screens. If I do a soft reset, it all comes back. At least for a while. Help anyone??
  • Admin
  • Forum posts: 2,322

Mar 24, 2014 7:02:23 AM via Website

@Bugs it seemed weired, well i am afraid but factory resetting might be the option to get the signal bar back if the problem is with the update. Look sometime updates needs to be reinitialised in order to work correctly. I would suggest you to backup your data and run a factory reset.
Loie Favre
  • Admin
  • Staff
  • Forum posts: 1,116

Mar 24, 2014 11:44:50 AM via Website

Hey there!

Here is what I suggest:
  • Make sure Wi-Fi is turned off on the handset.
  • To make sure both your incoming and outgoing calls are failing, have two separate parties call your number, and try making a call to two separate numbers.
  • If this line has Family Allowance, make sure time of day and minute limits are not restricting usage
  • Turn off your handset and remove the SIM card.
  • Make sure your SIM card does not have any scratches and is inserted correctly. Check the documents for your device for the steps to insert the SIM card
  • Put the SIM card back in the device and turn it on.
  • Test outgoing and incoming calls. Continue troubleshooting if the issue remains.
  • For 3G and 4G devices, switch to 2G. See Change Band under Settings in the documents for your device.
  • For 3G and 4G devices, switch back to 3G/4G.

If the problem persists, it would be wise to contact your carrier on this issue.
  • Forum posts: 1

Apr 11, 2014 4:24:45 PM via Website

@Loie I changed my SIM (got a new one from my carrier). Did at least 5 soft resets. Finally did a Factory Data Reset. Lost all my data and the problem still persists.
  • Forum posts: 6

Apr 12, 2014 1:10:40 AM via Website

I tried everything including factory resets. Even got a new sim card and still will not work. I have to do a reboot each time I want to check msgs. Even showing 3-4 good bars, sometimes manually checking msgs and email comes up with nothing. Preform a reboot, and suddenly 4-5msgs and 10 email shows up. Yes I checked and rechecked all settings.
So I have sent the phone in for a warrenty repair and received a loaner which arrived missing parts. So now I have NO phone for at least one week till I receive yet another loaner or my phone is returned. This phone was my primary phone so now I have no communations at all. NOTE, prior to the KitKat OS installation the S4 worked flawlessly.
  • Forum posts: 1

Apr 14, 2014 6:27:34 PM via Website

Got a very similar problem with S4 after kitkat upgrade. Worked fine before, now disables mobile data every 2/3 days and claims there is no sim card when try to reactivate. Sim card works fine for calls and texts

  • Forum posts: 3

Jun 2, 2014 12:45:52 PM via Website

thanks for the post ,

  • Forum posts: 6

Jun 2, 2014 1:14:48 PM via Website

Ok, the latest is; I contacted Samsung and sent phone off for repair. After two weeks where samsung replaced main motherboard and a few more bits and extensivly tested I received the phone back, replaced the sim and battery rebooted and still have the orginal problem.
My wife has identical S4 however she still has not preformed the KitKat upgrade and her phone works flawlessly. I switched sim cards between phones and prob came back on my orginal phone.
Conclusion is that the KitKat upgrade is not compatable on the "Bell" system. And yet my first repair was by Bell, however they only looked at the physical phone and not the programing.
I understand altough you cannot go back to an earlier OS system, it may be possible to replace only the portion of the program dealing with the actual carrier signal. Any comments? As I understand it, each carrier, Bell, Telus, Virgin, Fido etc uses a different portion in the OS and this is what is delaying the KitKat fix. So how do I repair the OS to fix the buggy Bell system? Again my wifes identical phone not on Kitkat works fine. Mine has been repaired and checked, factory resett, and all other tests and still fails. Both phones side by side can have 3 or 4 good bars signal strength. All setting are the same. A quick search of email, wonder around facebook and back to main screen and all my bars are gone. Hers are still there. A few minutes later and I have loss of signal. A reboot and everuthing comes back. For a while, then disapears again. Need a solution ASAP or out the window it goes!!!!

  • Forum posts: 1

Jul 3, 2014 11:48:17 AM via Website


This is certainly a firmware issue. Something about the phone's hardware is not compatible with the most recent software release. I presently have a phone (Galaxy S4) in my possession on the Cricket Wireless carrier that is giving me the "No SIM" treatment. It has been brought to the Cricket service center and the SIM card replaced, also the phone IMEI & ESN was registered to the proper account linked to the SIM. There is another weird message happening sometimes when I start the phone: "ME rejected". Does that sound familiar?

  • Forum posts: 6

Jul 3, 2014 1:08:40 PM via Website

My issue seems to be solved. Not sure how it happened but after the KitKat upgrade my carrier always looked for a "LTE" signal. If it found none, instead of switching to next available carrier speed, it locked up and stopped receiving/sending. I could not select the "Auto connect" as it continually looked for the LTE. I am on Bell system so I had a bell technician "disable" the LTE on my account. This then allowed the phone to permanently default to the best signal other than LTE. Phone has worked flawlessly since. Both mine and wife's S4.
So something in the KitKat OS has a prob switching between LTE mode and anything else. Perhaps this will be fixed in the next upgrade.
I am located in an rural area with only one tower not very close supporting LTE transfer rates hense my problem. Users in a larger city with available LTE towers could remain locked to LTE and not have any issues. However with me, all worked fine when I was close to LTE tower but when switching to non LTE tower, our S4s became confused and unable to switch to non LTE mode and just stopped working. Even when connected to my home WiFi. That Didn't matter at all.
And my S4 still does not see my Sd card ssme as everyone else! Hope that gets fixed on next upgrade!!

  • Forum posts: 1

Jul 17, 2014 9:51:41 PM via Website

I want to say thankyou to you Bugsy, I was having the same problems with S4 and was at the point of either chucking it into the sea and going back to apple or sending it back to Samsung for repair, (Both would have had the same outcome), but then I found your answer and fix. While its not perfect, (Still drops every now and then but with a far less frequency), I can now use the phone again. I have also noticed that there is a patch to be released to repair the shoddy, bug ridden 4.,4.2.

Once again, thankyou

  • Forum posts: 6

Jul 18, 2014 12:17:59 AM via Website

No problem. Took a long time but we finally sorted it out eh. Anyone else with this problem, try selecting anything besides LTE and set to default and autoconnect. Exit out of setup and then go back in and check again. If the LTE is still selected you may need to have your carrier (Bell, Rogers etc.) And have them disable LTE on your account.
Your dl rates will obviously slow somewhat but hey, at least you can use your phone again!!!

  • Forum posts: 1

Jul 31, 2014 8:09:50 PM via Website

my phone is Rogers and have unlocked it for my Telus account, I have used this with no problem for at least half a year with same custom rom, suddenly the problem just started happening, I change everything from updating radio, clean install rom, and even disabling lte and to only use lower modes, but to no avail, I don't think it's a compatability issue since I've used it with no problem for half a year, I read somewhere that it's caused by an older bootloader which I have,not sure if that would be true. Anyways I'm still looking for a fix. Will try different rom, see if it fixes it, if not I'll replace the Sim port.

  • Forum posts: 1

Aug 13, 2014 12:12:26 AM via Website

Experiencing the same issue and regretting having updated my once wonderful phone. I once praised this manufacture and model line after having jumped ship on iPhone's. A big company eyebrow raising act and now find myself ready to throw this thing into the street with missed calls and auto reboots! Screen was locking up but found a solution from another blog to remove the custom message on the lock screen. Just so bad of Samsung to release this update without thoroughly testing the firmware before rolling out. I have never hesitated before as I had built up a strong trust for them.

If an update to fix the update is not quickly release the will tarnish their reputation in my eyes for a long time and as an IT individual who is normally the one leading the masses around me it will have ripple affects! I will only keep rebooting my phone for so long.....

  • Forum posts: 1

Aug 28, 2014 3:10:28 PM via Website

Had the same problem with my s4 dropping service all the time. I'm with Telus. This is how we fixed it. Go to: settings, connections, more networks, mobile networks, network mode, then select "wcdma/gsm (auto connect)". I was told that after the update phone was set to search for LTE networks and if they couldn't be found it would freeze and drop service. Since changing that setting I have had no issue at all. Hope that helps!

  • Forum posts: 1

Sep 9, 2014 3:08:24 AM via Website

I have had this same problem with my Galaxy S4, it has gotten so bad that I had to pull out my old iPhone 4s because it was just unbearable and unacceptable. Randomly, I would lose all service, outgoing calls just say "Call Ended" after a few seconds with no ringing tone, incoming calls and texts are not recieved until I reset the phone. Call are randomly dropped when I am losing it. I am not sure if it is due to the kit kat update but it is a great possibility since the phone in terms of performance was lackluster after the update. I also heard that my Antenna inside the phone could be loose or damaged from drops. Either way it is very disappointing as I have only dropped the phone about two times from what I remember as opposed to the unfortunately high number of times I dropped my iPhone. Does anyone have any suggesstions or am I stuck with a $700 paperweight, or possibly a small tablet.

  • Forum posts: 1

Oct 20, 2014 8:27:43 AM via Website

Hello i belive ive found the source of the problem..
go to settings - connections - more networks - mobike networks - then go to netwlrk opperators with your data turned off, it takes a whike to populate the list. I ticked the box of my provider (o2) from a box marked "automatically sellect prefered network"
i also changed the network mode settings from the top one with LTE to the second one down that leaves the LTE bit out.
i dud this as its sometime to do with 4g i think. And my sin is still only 3g at the mo...
im not very sa y at this stuff usually but , 2 days and no drop out. Where as i was restarting my device 6 times a day before...
hope this helps...

  • Forum posts: 50

Oct 20, 2014 10:03:07 AM via App

Don't bother with the factory reset. mine has been doing the same thing since June, I've reset twice and it doesn't help.

  • Forum posts: 1

Nov 25, 2014 1:34:05 AM via Website

I was about to downgrade my Amoi A928W back to jelly bean until I read this post. I actually got an account so I could respond. I use straight talk which does not usually have 4g in my area so my phone locks up the sim card trying to find the 4g. You can force your phone to stay in 2g/3g mode by downloading the android xposed kit for your phone, download the gravity box module and manually set the antenna with the phone tweak settings within. Keep in mind, this can only be achieved through root. Bam. Problem free ever since. Well, 2g is slower than an army of turtles marching uphill through peanut butter but that's cause I live in the boonies. Hope this helps!

  • Forum posts: 1

Dec 26, 2014 11:49:36 PM via Website

My Galaxy S4 did same. Signal dropped out in places where it was fine before. I had a new Sim card installed but that didn't work. Did the factory restore didn't work either. Now I have to just restart the phone and it comes back for awhile. It's like when I move to a different location, it's not picking up a better tower? Dunno....(thinking)