Samsung Galaxy S3 — Wifi - security type unknown

  • Replies:8
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Aug 19, 2014, 6:00:13 PM via Website

When I try to hook up to the wifi at my workplace, the choice I have for the workplace wifi has "security type unknown" underneath the name, and I cannot click on it to enter password. Any ideas?

Reply
  • Forum posts: 1

Aug 5, 2016, 9:05:29 PM via Website

I had the same problem, but I fixed it this way:

Settings > Wi-fi > + Add Wi-Fi network > Enter the network name in Network SSID, select the security type ( WPA/WPA2 PSK) and enter the password if it is not an open network, and then tap Connect.

I hope I I have helped.

Al NapieralaKhalid RoumiehGian Vitola

Reply
  • Forum posts: 1

Sep 20, 2016, 4:34:49 AM via Website

This works. Thank you very much for your help!

Reply
  • Forum posts: 1

Sep 22, 2016, 1:06:11 PM via Website

Hi Isabella,
I am having the same issue, my work WiFi shows security type unknown and I cant connect to it now though it used to connect previously.
When I go to Settings -> WiFi , it shows the listof WiFis and signal strengths ( including my Work WiFi), but I cant find the option to Add WiFi network as you said.

Reply
  • Forum posts: 1

Jun 14, 2018, 12:45:53 AM via Website

Same issue here! :(
I've googled it and nothing that can save me :c

Reply
  • Forum posts: 1

Jul 24, 2018, 3:49:09 PM via Website

scroll to the end of your list of conections its at the bottom.. it took me a few min to fig out.. its there and it works

Reply
  • Forum posts: 400

Jul 25, 2018, 3:10:22 AM via Website

Jeff
This is a shot in the dark but here goes.
That WiFi signal could be accessible only by certain device numbers, and your device number is not on the list!
Or
If you have your cookies shut off and your device number cannot be seen. That could stop you from using that signal.
Just a thought I had!
Lindsay

Reply
  • Forum posts: 2

Aug 7, 2018, 8:05:54 AM via Website

Easy put alp info yourself just like this...
Settings > Wi-fi > + Add Wi-Fi network > Enter the network name in Network SSID, select the security type ( WPA/WPA2 PSK) and enter the password if it is not an open network, and then tap Connect

Reply
  • Forum posts: 2

Aug 7, 2018, 8:06:47 AM via Website

Settings > Wi-fi > + Add Wi-Fi network > Enter the network name in Network SSID, select the security type ( WPA/WPA2 PSK) and enter the password if it is not an open network, and then tap Connect

Reply

Recommended articles