Samsung Galaxy S3 — S3 kitkat installation loop

  • Replies:3
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Feb 11, 2015 6:25:22 AM via Website


I wonder if anyone can help me with this one!

I have an S3 GT-I9305 that was running on jellybean (not sure which version). I recently revieved a push message to update my OS to kitkat. After it downloaded I was asked to approve the installation which I did.

Once the installation reaches 100% the phone restarts, displays the model name and then starts installing the update again in a continuous loop. It will continue this until the battery is flat. I have taken the battery out for 10 minutes, but on turning the phone on it starts the installation again and enters the loop.

I have tried entering safe mode by holding down the power, home and volume+ buttons, this causes the phone to restart, but doesn't get me into safe mode. The loop continues.

I have tried the above method, but taking my finger off the power button when the model name is displayed - does nothing.
There is no vibration or anything. The loop continues.

I talked to a help desk who advised me to take me phone to a service center in the country I bought the phone (Australia). Unfortunately I'm on assignment in Nepal and won't be home for some time (maybe year or two).

Any assistance would be appreciated.

I'm thinking I will need to do some kind of external boot either through a usb or maybe an SD card so I can do a factory reset or something. Is it possible to do this?


  • Forum posts: 663

Feb 13, 2015 4:27:52 PM via Website

Go to recovery mode , then clear cache then data
if you can't access recovery mode . then ,download the latest firmware and flash it with odin.

Ready To Help You.

  • Forum posts: 2

Feb 16, 2015 4:40:06 AM via Website

Unfortunately I can't enter recovery or safe mode. Will odin software override the phone start-up boot?


  • Forum posts: 663

Feb 17, 2015 4:15:27 AM via Website

you need to download the latest firmware then flash it using Odin.. This will solve any bricks.
You need to boot in to the download mode to flash the firmware

Ready To Help You.