Samsung Galaxy S4 — Messages (sms app) s4 lollipop not showing messages

  • Replies:16
  • OpenNot stickiedUnanswered
  • Forum posts: 4

Apr 4, 2015 7:30:42 AM via Website

I updated my s4 gt-i9505 phone to lollipop yesterday and now the messages sms app doesnt show the text or the conversation.
It does show the first few words of the latest text in the conversation in the list of conversations but when i go to read the full text message the individual conversation screen is blank.
Any ideas on how to fix?

  • Forum posts: 746

Apr 4, 2015 8:07:07 PM via App

In settings, go to sounds/notifications, at the bottom click 'show on lockscreen'.

Sinkster

  • Forum posts: 2

Apr 5, 2015 3:14:54 AM via Website

I have the exact same problem. Truncated previews of SMS messages show up as notification and in the SMS message index, but when opening a message, it only shows a blank screen. It is impossible to open any SMS message.

Sinkster's answer is not addressing the issue. The issue is not that it does not show up in notifications or on the lockscreen. It's the message itself that is not readable in single message view.

I cannot access one of my bank accounts now, since it uses two way verification - I can see that my bank sent me a message containing a verification code, but have no way to read the actual verification code which is hidden in the full message which is inaccessible..

— modified on Apr 5, 2015 3:21:53 AM

  • Forum posts: 4

Apr 5, 2015 9:20:14 AM via Website

Thats it exactly Jeroen.

I have found a workaround (accidently). Try using 'Hangouts' instead of 'Messages' (It was buried in the apps somewhere) as this can be set as your default sms software. I prefer 'Messages' but at least you can see the text of the message in 'Hangouts'.
And hopefully when they fix the bug we can go back to 'Messages'.

  • Forum posts: 2

Apr 5, 2015 2:02:59 PM via Website

[[cite igi]]
Try using 'Hangouts' instead of 'Messages' (It was buried in the apps somewhere) as this can be set as your default sms software. I prefer 'Messages' but at least you can see the text of the message in 'Hangouts'.
And hopefully when they fix the bug we can go back to 'Messages'.

Confirmed.. Works for me too. Thanks for sharing!

  • Forum posts: 1

Apr 6, 2015 8:39:04 PM via Website

Hi Guys,

I have been having the same problem with the sms not showing up.

I tried that hangouts suggestion and it only seems to be if the people you are speaking to are also on hangout you can view the messages.

Does anyone know of any other way to view the sms?

Thanks :)

  • Forum posts: 4

Apr 7, 2015 8:33:57 AM via Website

Hi Kerrie,

I can see texts from people that are not using Hangouts, so im not sure but hopefully this might help.

Have you got hangouts set as your default sms app?
1. Go to Hangout settings (top left hand corner of the app - 3 horizontal lines)
2. Click on Settings
3. Click on SMS
4. Click on 'SMS Enabled'
5. If 'default messaging app' isn't hangouts, then click on the setting and change it to hangouts

  1. Go to Hangout settings (top left hand corner of the app - 3 horizontal lines)
  2. Click on Settings
  3. Click on SMS
  4. Click on 'Default SMS Messaging Account'
  5. Select 'SMS-only account'
  • Forum posts: 1

Apr 11, 2015 3:46:58 AM via Website

I found a free app on the PlayStore called Textra that works quite well . This is what I'm currently using until Samsung get the Messages app fixed .

  • Forum posts: 1

Apr 11, 2015 9:43:58 PM via Website

Thank you so much igi I have had a stressful day because of this update (angry) but having found this forum I have now managed to sort out my text messages. The other problem I had is that I could not connect to WiFi but that seems to have rectified itself now. :?

  • Forum posts: 1

Apr 13, 2015 10:18:06 PM via Website

Hi thankyou for that, now i can view all of my messages again finally while the stupid update is fixed! Works a treat after reading that hangouts needs to be set as default.

Thanks again

  • Forum posts: 1

Apr 21, 2015 10:22:11 PM via Website

I have same problem,after upgrading on 5.01 lolipop.This with messaging is really iritating.I try hangouts,and this other sms app,but,i had problem,i didnt get few sms from ppl.Solution wich i found is to go to app manager,and remove updates from Messages app.Now it work corectlymbut lolipop is make my Galxay S4 much slower,it crash pretty often,im really disapointed.It is visually nicer,but more the 1gb update???? My ram is nonstop over 80%.I expect more from Samsung,seems they didnt heard about optimization.

Damir Stipetic

  • Forum posts: 1

Apr 25, 2015 9:33:32 PM via Website

Thank you, Sinkster, you may not have soled the op's issue with this reply but you did mine! My S4 updated to Lollipop two days ago and I have been going crazy every time I have gotten a text and had to go into the app to see who it is from! Thanks!

  • Forum posts: 4

May 1, 2015 11:27:24 AM via Website

Good news (for me at least) I got a android update (385MB) this morning and Message works properly again. Hopefully you will get the same update soon.

  • Forum posts: 1

Jun 6, 2015 7:47:54 PM via Website

I have figured it out! Go into messages where you would click Preview message. There is a place to check "show message on all screens except the lock screen". It lies. It shows it on the lock screen too!
Messages » three lines » settings » notifications » check mark pop up display » yay!

DISCLAIMER: I have just done this, and tested it with a galaxy and with an iPhone. It shows the message on the lock screen, but a popup does appear on regular screens as promised. I can't speak to how annoying it will be to have to swipe a message away when you're actually doing something on your phone

— modified on Jun 6, 2015 7:48:13 PM

  • Forum posts: 1

Jun 8, 2015 7:58:17 PM via Website

My text notifications used to show the name of the person who sent the text, or a string of numbers (which let me know that I was receiving a FaceBook notification). Now I have to actually open the text screen to see who has sent me a text so that I know if I need to look at it in the moment or if it can wait until later. How long before the system will be updated again so that I can see who is texting me? Thank you.

  • Forum posts: 2

Jun 26, 2015 12:39:50 AM via Website

Hi mate.. Had the same problem... go to messages.. then menu , or the 3 lines as can be the case.... settings... notifications. ... at the bottom of the page u will see "preview message" check that box with the green tick. You will now get the notification at the top of your page with the senders name. Cheers..

  • Forum posts: 2

Jun 26, 2015 12:50:21 AM via Website

Hey mate.. if u don't want the pop ups on every screen just uncheck that box and just check the box below.. it'll just give u a notification at the top of ure screen with the senders name....